Zebra zq520 is not printing zpl properly

I have created an app that will print invoice and converted it to zpl , when I see the zpl code in http://labelary.com/viewer.html , it looks perfect , but when I print this in actual printer , it prints totally gibberish. in my invoice i have an image and some text and numbers , converted zpl code with image and text looks perfect in web viewer but when I print in real device , it is printing logo multiple times but no text is printing .

What is possible reason for this?

My generated zpl command is given below

^XA^FO250,50,^GFA,1280,1280,32,:Z64:eJyl0kFuwyAQBdBBSGFXLhDha3RhyVfqkkhRzcG64CgcgaUXVt0PhBonFrPISFGSeYaZwRDlEBv1Y/Z917HvcmUK/DI+ub4Poe+KaVC83SDjgz/LbitpfM0bqYAmHU2bI4GfVvuU3V3GsbgngVns4JB1u4vFVpcLfEpZh52SW3zuMfkoH45570SNT6G6gt2WnG0cAzxc/2DvkNej21wfHWlf62tTLgyyjStf5zOnrmNdb4ay/+6pvllyfeHzHmnFsb/Rtn5bn92Otf8ZNez3v28hnR9FU+tbPNOcX3ERdPUoA87fH1165cp8IuIFWZWyrn3X8vDvNeTpDdkjXYtuMFecvhj/fNOvjH8wfmFcMS4ZF+4l9QfeF52N:34a1^FS^FO800,220,1,0^FB800,1,0,R,0^ADN,20, 10^FDTestCo^FS^FO800,240,1,0^FB800,1,0,R,0^ADN,20, 10^FD26985 116th Avenue^FS^FO800,260,1,0^FB800,1,0,R,0^ADN,20, 10^FDMaple Ridge, BC, V2W 1N1^FS^FO800,280,1,0^FB800,1,0,R,0^ADN,20, 10^FD(604) 637-6528^FS^FO800,300,1,0^FB800,1,0,R,0^ADN,20, 10^FDinfo@flexibake.com^FS^FO20,320,0,0^FB800,1,0,L,0^ADN,20, 10^FDClone #1 of Creative Cuisine^FS^FO20,340,0,0^FB800,1,0,L,0^ADN,20, 10^FD211 Interurban Road^FS^FO20,360,0,0^FB800,1,0,L,0^ADN,20, 10^FDVictoria, BC V7M 8K8^FS^FO20,380,0,0^FB800,1,0,L,0^ADN,20, 10^FDInvoice 624^FS^FO20,400,0,0^FB800,1,0,L,0^ADN,20, 10^FDSales Order: 860^FS^FO20,420,0,0^FB800,1,0,L,0^ADN,20, 10^FDDelivery Date: 22/01/2020^FS^FO20,460,0,0^FB600,10,0,L,0^ADN,20, 10^FDCODE^FS^FO155,460,0,0^FB600,10,0,L,0^ADN,20, 10^FDDESCRIPTION^FS^FO500,460,0,0^FB200,10,0,L,0^ADN,20, 10^FDQTY^FS^FO600,460,0,0^FB200,10,0,L,0^ADN,20, 10^FDPRICE^FS^FO700,460,0,0^FB200,10,0,L,0^ADN,20, 10^FDTOTAL^FS^FO20,480,0,0^FB200,10,0,L,0^ADN,20, 10^FD-----^FS^FO150,480,0,0^FB200,10,0,L,0^ADN,20, 10^FD------------^FS^FO500,480,0,0^FB320,10,0,L,0^ADN,20, 10^FD------------------------^FS^FO20,520,0,0^FB150,1,0,L,0^ADN,20, 10^FDRS-BP1^FS^FO155,520,0,0^FB380,2,0,L,0^ADN,20, 10^FDBagel, Plain (ea)^FS^FO500,520,0,0^FB320,1,0,L,0^ADN,20, 10^FD7^FS^FO550,520,0,0^FB100,1,0,R,0^ADN,20, 10^FD0.50^FS^FO650,520,0,0^FB100,1,0,R,0^ADN,20, 10^FD3.50^FS^FO20,560,0,0^FB150,1,0,L,0^ADN,20, 10^FDWB^FS^FO155,560,0,0^FB380,2,0,L,0^ADN,20, 10^FDWhite Bread^FS^FO500,560,0,0^FB320,1,0,L,0^ADN,20, 10^FD10^FS^FO550,560,0,0^FB100,1,0,R,0^ADN,20, 10^FD3.00^FS^FO650,560,0,0^FB100,1,0,R,0^ADN,20, 10^FD30.00^FS^FO370,600,0,0^FB200,1,0,R,0^ADN,20, 10^FDDelivered^FS^FO650,600,0,0^FB100,1,0,R,0^ADN,20, 10^FD33.50^FS^FO370,630,0,0^FB200,1,0,R,0^ADN,20, 10^FDSubtotal^FS^FO650,630,0,0^FB100,1,0,R,0^ADN,20, 10^FD33.50^FS^FO630,650,0,0^FB320,10,0,L,0^ADN,20, 10^FD--------------^FS^FO370,680,0,0^FB200,1,0,R,0^ADN,20, 10^FDDelivery Fee^FS^FO650,680,0,0^FB100,1,0,R,0^ADN,20, 10^FD5.00^FS^FO630,700,0,0^FB320,10,0,L,0^ADN,20, 10^FD--------------^FS^FO370,730,0,0^FB200,1,0,R,0^ADN,20, 10^FDTotal^FS^FO650,730,0,0^FB100,1,0,R,0^ADN,20, 10^FD38.50^FS^FO370,760,0,0^FB200,1,0,R,0^ADN,20, 10^FDInvoice^FS^FO650,760,0,0^FB100,1,0,R,0^ADN,20, 10^FD38.50^FS^FO370,800,0,0^FB200,1,0,R,0^ADN,20, 10^FDNet Balance:^FS^FO650,800,0,0^FB100,1,0,R,0^ADN,20, 10^FD38.50^FS^FO20,960,0,0^FB780,1,0,L,0^ADN,20, 10^FD------------------------------------------------------------------------------------^FS^FO20,990,0,0^FB800,1,0,L,0^ADN,20, 10^FD Terms: DUE UPON RECEIPT^FS^FO90,1010,0,0^FB800,1,0,L,0^ADN,20, 10^FDThank you for your order.^FS^FO20,1040,0,0^FB780,1,0,L,0^ADN,20, 10^FD------------------------------------------------------------------------------------^FS^XZ

Alexander Palchikov
Hi Mithun

Hi Mithun

I’ve just tried to print your code on my printer and it was printed exactly as at the preview.

Looks like there are problems in your printer settings. Try a hard reset and also update firmware if the version is not the latest.

 

If the problem will reproduce after that then please share a result of following SGD command: ! U1 getvar "allcv”

You can capture SGD command result following the advice in this article.

 

 

Alexander Palchikov

Software Engineer, Kutir Mobility

Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments