Any reason why I can't have Alert.vibrate work for windows mobile?

Hi, I'm trying to add vibration to my windows mobile app on a windows mobile MC75.

I added "vibrate" to the capabilities section in build.xml and called Alert.vibrate from my ruby controler, but nothing happens.

Is there something to add to the html or to a config file to have vibration working on windows mobile?

Vinod Shankar K
Hi, Can you try with Alert

Hi, Can you try with Alert.vibrate 2000 with some duration in your Ruby code.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Nicolas Grolleau
Hi, thanks for helping.I

Hi, thanks for helping.

I tried with no parameter (as the default value should be 2500), with 2500 and with lower values, but nothing had effect.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Vinod Shankar K
Hi, Its a known issue in RMS

Hi,

Its a known issue in RMS 2.2 version.

If you can refer to release note it is mentioned as below,

  • The Alert.vibrate function does not work on Windows Embedded Handheld 6.5 devices.
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Nicolas Grolleau
Thanks.Do you know if this

Thanks.

Do you know if this will be corrected in 4.0?

Is there an other way to have a vibration on MC75?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Vinod Shankar K
In 4.0 there is new API for

In 4.0 there is new API for vibrate, you can refer to following link http://edgedocs.rhomobile.com/api/Notification#mvibrate

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments