How to disable barcode scanner from pasting output to focused Edittext?

Hi,

 

I'm trying to integrate ET 1 bar-code scanner in my application. I have created a profile to receive the bar-code scanner's output via intent and processing the same. But my problem is if any EditText is in focused state while scanning, then the inbuilt barcode scanner is pasting the output to that view.

 

Output via Intent is enough for me, i don't want bar-code scanner to past the output in my views.

 

Can someone tell me the way to block this.?

 

Thanks.

Anonymous (not verified)
In your DataWedge profile did

In your DataWedge profile did you uncheck Keystroke Output Enabled?

Also did you disable the other DataWedge profiles?

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Abbas Abbas
UnChecking the keystore

UnChecking the keystore solved the problem.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Salo Sugek
posting so I can see thread

posting so I can see thread

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments