Zebra Zmotif Series Printer Emulator not visible to demo app

Zebra Zmotif Series Printer Emulator not visible to demo app

Zebra Zmotif Series Printer Emulator not visible to demo app


Audience

I have to make an app that will personalize smart cards, both optically and electronically. I don't have the printer ZXP Series 9 with me yet, but it's coming. In the mean time I wanted to try at least something, which brings me to the emulator.
I've downloaded the ZMotif SDK and the emulator from this link: https://www.zebra.com/us/en/forms/card/zxp-downloads.html
I had to stop my IIS because emulator requires port 80 to start (otherwise I get error message "Failed to bind emulator to HTTP port 80"). When I start the emulator it asks me to select a printer. I select ZXP Series 9, and click on Ethernet Printer (button "USB Printer" is disabled in all cases). Netstat command shows that ports 80 and 9100 are open for listening.
I copied the demo project from the folder in ZMotif SDK: ZMotif SDKs\SampleCode\ZXPSampleCode.
I had to convert the project to VS2017, and upgrade target framework to .NET Framework 4.7.2. When I start the demo I'm greeted with a warning "Could not locate a ZXP Printer on USB ports", which is fine. When in Discover Printers group box I select Ethernet and click on Locate Printers I get error message "Could not locate a ZXP Printer via Ethernet", which is unexpected.
What am I doing wrong here? I assumed that demo app would find the emulated printer.
I tried to temporarily pause my antivirus software, but the emulator was still not found.