Help on APD within ET1 and QL320plus printer

From ET1, I am trying to make a printout on QL320plus printer make of Zebra by using Bluetooth technology.

On ET1, I am using Android version 2.3.4, with RhoElement version 1.0.3.2.


By taking the help from documentation of APD Programmers manual, we develop one application. And this application is successfully working on MC75 with the same printer.

But when we run this same application on ET1 it is not working.

For reference the developed html5 page is attached, please check.

In this the PID we used is BC53:1.

Can anyone please help on this.

Daljinder Singh
Daljinder Singh wrote:From

Daljinder Singh wrote:

From ET1, I am trying to make a printout on QL320plus printer make of Zebra by using Bluetooth technology.

On ET1, I am using Android version 2.3.4, with RhoElement version 1.0.3.2.


By taking the help from documentation of APD Programmers manual, we develop one application. And this application is successfully working on MC75 with the same printer.

But when we run this same application on ET1 it is not working.

For reference the developed html5 page is attached, please check.

In this the PID we used is BC53:1.

Can anyone please help on this.

Please if someone can help on this?

I am waiting for response from last 9 days.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Gregory Pawlik
Hello Daljinder,My only

Hello Daljinder,

My only suggestion concerning your test.html code is to remove the $$[CMD:0101,1]$$\r\n\r\n portion of the data stream you are sending to the printer.  It is not part of the QL 320 PLUS printer's native language.

Other than that, it looks fine.

Try pairing the ET1 with the printer just to verify that you can actually connect to the printer via Bluetooth.

Assuming that you are using the correct MAC address, check the Bluetooth Channel that the printer is on.  Your PID, BC53:1, indicates that your printer is on Bluetooth Channel 1.  If your printer is on Channel 2, change your PID to BC53:2 or to whatever Bluetooth channel your printer is assigned by the ET1.

Also, be sure that you have the latest firmware on the QL 320 PLUS. 

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Robert Galvin
Hi Dajinder I tried your page

Hi Dajinder

I tried your page with the exception of changing the BC53:1 to a BC52:1 and of course my MAC address. Although I am using a Zebra MZ320 the BC52 worked. Can try BC52 instead of BC53? Also, make sure the mac address is exactly what you have (print the diagnostic page to double check). Otherwise the code looks good. I click Print Id and then click Print Hello. After clicking print Hello, I see a popup dialog “Adaptive Printer driver, Connecting, then a progress bar for printing” Do you see that at all? Also set the log options in the config.xml and look at the log file. The adaptive printing on the ET1 is all included and should not need any pairing/setup outside of the RhoE application.

Rob

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Robert Galvin
DajinderAlso, this message

Dajinder

Also, this message was originally posted to the wrong space. You posted to the Launchpad Help space which is setup just for site type questions. I moved this post to the which is aligned with all topics relating to RhoElements.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


John Stumpf
I'll reach out to Zebra and

I'll reach out to Zebra and get an answer.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Daljinder Singh
Many many thanks to all for

Many many thanks to all for your valuable reply.

As mentioned, previously i was using RhoElement version 1.0.3.2. Now when i upgrade it to 1.0.3.6, the same code works and i got the print out with same setup.

Thanks Rob, next time i will take care of the space , where to put the questions.

Thanks Greg, without that line it prints.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments