4 Replies Latest reply on Apr 27, 2012 5:24 AM by steve westergaard

    Signal Indicators

      Can the Signal Indicator be used to detect a WiFi Signal?  The battery indicator appears to work fine with the same Content Settings.

       

      The image on this page appears to show Wifi

      http://edgedocs.rhomobile.com/rhoelements/IndicatorPositions

       

      For reference

      http://edgedocs.rhomobile.com/rhoelements/signal

       

      I show the following in my MC65A logs, and no indicator appears.. 

       

      <META HTTP-Equiv="Signal" Content="Left:447;Top:5; Color:#FF0000; Layout:Left; Visibility:Visible">

       

      I 04/25/2012 12:21:38:777 e7fdd592 RhoElementsExt_wm.cpp:  43| Received Meta Tag, Module: viewport Contents: width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0

       

      I 04/25/2012 12:21:38:830 e7fdd592 Core::CMeta::GetModule| Plug-in: viewportcannot be found in Plugin.xml

       

      W 04/25/2012 12:21:38:833 e7fdd592 Core::CMeta::SetPlugProperty| Module viewport not found.

       

      I 04/25/2012 12:21:38:837 e7fdd592 RhoElementsExt_wm.cpp:  43| Received Meta Tag, Module: Signal Contents: Left:200;Top:5; Color:#FF0000; Layout:Left; Visibility:Visible

       

      I 04/25/2012 12:21:39:018 e7fdd592           MainWindow| OnSize: x=480;y=640

       

      I 04/25/2012 12:21:39:060 e7fdd592           MainWindow| OnSize: x=480;y=640

       

      W 04/25/2012 12:21:39:202 e7fdd592 Controls::CControlsModule::MetaProc| WLAN support not available

       

        • Re: Signal Indicators
          Robert Galvin

          Steve

           

          The Signal object displays information on an AP that the device is associated with. It does not act like 'View wireless networks' showing available APs. If your device is on WiFi the signal indicator should show information for the AP.

           

          Have you tried javascript or registering for the signalEvent to see if any information is coming in? Which device are you using?

            • Re: Signal Indicators

              Rob

               

              That's right I'm attempting to see if the signal (icon) appears while I'm connected internally to our wifi, by placing the above META Tag. It worked with no issues when using the Battery tag.  I did not register for any events on my first few attempts, I assumed it would appear regardless.

               

              I've registered the control and I still am not seeing anything in the logs or on the view..

              I 04/26/2012 14:39:58:477 0a1a5cb6     Core::LoadPlugin| Signal
              I 04/26/2012 14:39:58:479 0a1a5cb6    Abstract::Preload| First call
              I 04/26/2012 14:39:58:496 0a1a5cb6 Core::CSync::RegisterCallback| Registered Callback
              I 04/26/2012 14:39:58:497 0a1a5cb6 Core::CSync::RegisterCallback| Registered Callback
              I 04/26/2012 14:39:58:498 0a1a5cb6 Core::CSyncMsg::RegisterCallback| Registered Primary Callback
              I 04/26/2012 14:39:58:499 0a1a5cb6 Core::CSync::RegisterCallback| Registered Callback
              W 04/26/2012 14:39:58:512 0a1a5cb6 Controls::CControlsModule::onInit| Cannot load keyboard driver DLL
              I 04/26/2012 14:39:58:555 0a1a5cb6           MainWindow| OnSize: x=480;y=640
              I 04/26/2012 14:39:58:628 0a1a5cb6           MainWindow| OnSize: x=480;y=640
              W 04/26/2012 14:39:58:846 0a1a5cb6 Controls::CControlsModule::MetaProc| WLAN support not available
              

               

              As you can see the plugin loads, but does not render..

               

              Is there any sample code that I can try out..

               

              Also I'm using a MC65, I have a ES400, MC55, MC9596 that I can also try it on..

                • Re: Signal Indicators
                  Daniel Silva

                  I just tried this on an MC65, and it is working for me.  I do see the error that you see in the log if I shut off the WiFi radio, and in that case the icon also does not show up.  I also moved the position a little further down the screen, because the debug buttons sometimes load on top of things that are at the top (changed top from 5 to 55).

                    • Re: Signal Indicators

                      Thanks Dan.. The issue is resolved..

                       

                      I was receiving the WAN error message after building and deploying to the device through RhoStudio.The Wifi showed turned on, but the icon was not appearing on the view.

                       

                      After removing the device from the cradle, rebooting and restarting the app. The icon appears and shows that I'm connected to WiFi. Maybe WMDC was causing the issue.