Invalidating SMSESSION Cookie in RhoElements

In order to invalidate the SiteMinder smsession cookie, we use the following JS:

        document.cookie = 'SMSESSION=; expires=Mon, 31 Dec 2000 23:59:59 GMT; path=/; domain='+myDomain;

This does not appear to work for RhoElements. Does anyone have experience in using RE to access a SiteMinder site and invalidating the cookie?

Thank you

-tom howard

Robert Galvin
Hi TomWhat version of RhoE

Hi Tom

What version of RhoE are you using? Does it think the cookie is still there or there seems to some other effect?

Thanks

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Thomas Howard
We're using 1.0.2.3. It

We're using 1.0.2.3. It thinks the cookie is still there and the browser is being redirected to the home screen rather than the login screen (this occurs during the logout process).

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Darryn Campbell
Hi,I think the cookie is

Hi,

I think the cookie is still there, you can use the new version 1.0.3.11, available on the site .

http://support.symbol.com/support/search.do?cmd=displayKC&docType=kc&externalId=13526&sliceId=&dialogID=347684564&stateId=1%200%20347676236

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Thomas Howard
1.0.3.11 doesn't work for

1.0.3.11 doesn't work for some reason. When trying to access the login page, I get "Server Error. The server was unable to process your request." I thought I saw this as a known issue somewhere, but I'm unable to find it at the moment.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Glenn Sayer
Thomas,what device are you

Thomas,

what device are you using?

found the below in the release notes.

On the ET1 it is currently not possible to access HTTPS sites that have self signed certificates

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Darryn Campbell
Thank you for your reply. I'm

Thank you for your reply. I'm using the MC55A.

I see that RE2.0 has been released. I will see if that makes a difference.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Thomas Howard
Well, the good news is that

Well, the good news is that the SMSESSION issue seems to be fixed with 2.0. (Plus, I really like the fingerscrolling feature.)

The bad news is that I'm still getting the error "Server Error. The server was unable to process your request" if I try to hit any environment but my local development environment. I'm not able to determine what's causing this issue. Version 1.0.2.3 works fine, as do other desktop browsers, but v1.0.3.11 and v2.0 both show this error when trying to access our login page, which is located on a Websphere Application Server and routed through SiteMinder.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Robert Galvin
Thomas,Thanks for checking

Thomas,

Thanks for checking version 2.0 - glad to hear there was some progress. You may be hitting an issue we have with untrusted certs.

As a test can you try modifying the config.xml and add the VerifyPeerCertificate tag:

<Navigation>

<BadLinkURI value="file://%INSTALLDIR%\HTML\BadLink.html"/>

<UserAgent value="Mozilla/5.0 (%p) AppleWebKit/%w (KHTML, like Gecko) MotorolaWebKit/%e Safari/%w" />

<VerifyPeerCertificate value="0" />

</Navigation>

However please note that the above setting is unsupported and will only work on Windows Mobile / CE from the thread I could not tell what device you are using.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Thomas Howard
I'm using an MC55A running

I'm using an MC55A running Windows Mobile. I tried this configuration change, but I'm still getting the error.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments