8 Replies Latest reply on Jun 7, 2012 4:17 AM by Bratish Goswami

    No barcode.lib in rhoelements-2.0.5.27.0

      Hi,

       

      I have downloaded the new Motorola Rhoelements Suite and trying to build an barcode reader app for a motorola device (mc3190).

      We have RhoElements license. 

       

      The build process is throwing the following error:

       

      -----------------------------

       

      9>Generating Code...

       

      9>Compiling resources...

      9>Microsoft (R) Windows (R) Resource Compiler Version 6.0.5724.0

      9>Copyright (C) Microsoft Corporation.  All rights reserved.

      9>Linking...

      9>LINK : fatal error LNK1104: cannot open file 'Barcode.lib'

      Project : warning PRJ0018 : The following environment variables were not found:

      $(PLATFORMDEFINES)

      9>Build log was saved at "file://c:\MotorolaRhoMobileSuite2.0.5\ruby\lib\ruby\gems\1.9.1\gems\rhodes-3.3.3\platform\wm\bin\MC3000c50b (ARMV4I)\rhodes\Release\BuildLog.htm"

      9>rhodes - 1 error(s), 1 warning(s)

      Build complete: 4 Projects succeeded, 1 Projects failed, 0 Projects skipped

      Error building

      Error in build application

      -----------------------------

       

      My build.yml is following

      -----------------------------------

       

      extensions:

       

        - json

      wm:

        sdk: "MC3000c50b (ARMV4I)"

        emulator: "Windows Mobile 6 Professional Emulator"

        extensions: ["webkit-browser", "Barcode"]

      name: "BarcodeMotorola"

      capabilities:

        - motorola

      #  - camera

      wp:

        - camera

        - vibrate

        - phone

        - motorola

      productid: "99323d40-8c5d-012f-fbf2-54bed9c762fe"

      app_type: "rhoelements"

      bbver: 4.6

      android:

        version: 2.1

      applog: "rholog.txt"

      build: "debug"

      version: 1.0

      vendor: "rhomobile"

      sdkversion: "3.3.3"

      -----------------------------------

       

      In rhoelements-2.0.0.beta.3 there was barcode-moto.rb file and barcode-moto folder but nothing like this in the latest version.

       

      I've also tried copying barcode.lib from earlier rhoelements beta version but didn't work.

       

      Copied barcode-moto folder and barcode-moto.rb from \RhoStudio\ruby\lib\ruby\gems\1.8\gems\rhoelements-2.0.0.beta.3\libs to MotorolaRhoMobileSuite2.0.5\ruby\lib\ruby\gems\1.9.1\gems\rhoelements-2.0.5.27.0\libs


      This improves nothing and keeps showing the same error "LINK : fatal error LNK1104: cannot open file 'Barcode.lib'".

       

       

      Did anybody face the similar situation? Any help from the core team please!

       

      Any help please. Thanks.