can not take picture


log,on the windows mobile phone(Dopod s910,26 tables to sync)

E 05/18/2012 11:29:32:000 a5b4306e       Alert.cpp: 138| Failed to load icon

E 05/18/2012 11:29:32:000 a5b4306e       Alert.cpp: 288| internal error

E 05/18/2012 11:29:37:000 a5b4306e Camera| hLib: 14

E 05/18/2012 11:29:37:000 a5b4306e Camera| takePicture failed with code: 0x80004005

E 05/18/2012 11:30:46:000 a5b4306e Camera| hLib: 14

E 05/18/2012 11:30:46:000 a5b4306e Camera| takePicture failed with code: 0x80004005

E 05/18/2012 11:30:53:000 a5b4306e Camera| hLib: 14

E 05/18/2012 11:30:53:000 a5b4306e Camera| takePicture failed with code: 0x80004005

Any help?

Thank you!


Ariana Habbaba
Have you added the camera

Have you added the camera capability in your app's build.yml file?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Awa Huang
Yes ,i had.When i exit the

Yes ,i had.

When i exit the app,then restart it ,the function is okay; it sounded the Sync process relate to take picture.

Any idea?

Thank you so much!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Ariana Habbaba
So you're saying the first

So you're saying the first time you tried running it, you got this error? But when you exit and restart the app, it works?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Awa Huang
Yes.And when i reset the

Yes.

And when i reset the phone db  and sync again, the error also.

Thanks you reply!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Ariana Habbaba
How are you syncing?Are you

How are you syncing?

Are you using RhoConnect?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Awa Huang
Yes, my team develop a 

Yes, my team develop a  mobile application to test the rhomobile solution efficiency.The application sync 26 tables using rhoconnect to the backend service.

but  fall on the take picture often,we found it maybe relate with the syncing,or the mobile OS resource,because the take picture fail after  the sync finish,but if restart the application and sync ,the function is OK.

Any advice for help?

Thanks!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Evgeny Vovchenko
So sometimes take picture

So sometimes take picture works ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Hi, what device are you using

Hi, what device are you using?  We have known issues with the Camera on ES400 and MC65

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Awa Huang
I am using Dopod S910w,non

I am using Dopod S910w,non-Moto device.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Ah, thanks, it's not what I

Ah, thanks, it's not what I suspected then ... I'll let somebody more knowledgeable on the RhoSync / Camera API side take this one

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Awa Huang
Thank you!Never mind!

Thank you!

Never mind!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments