How to define controller for top-level index.erb

http://docs.rhomobile.com/faq

I changed rhoconfig.txt to launch a different model as the start_path, but every time I run the simulator (and possibly direct-to-device) the rhoconfig.txt is overwritten with start_path="/app".

Is this a bug, or am I missing something obvious here?

Lobby Jones
"This is issue with Run/Debug

"This is issue with Run/Debug Configuration dialog – it replace start_path in rhoconfig

Run application from toolbar – it will not overwrite start_path"


from: https://groups.google.com/forum/?fromgroups#!topic/rhomobile/zzOP3dDRDe8

Sure enough, running the app from the toolbar leaves the start_path intact.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Robert Galvin
LobbyThis is a bug. You can

Lobby

This is a bug. You can try closing the file after you make the change and before you do the run. Rhostudio is over writing it when it starts the run process. Another method is to change the start page via code instead of rhoconfig.txt

Sent from my Verizon Wireless 4G LTE DROID

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Lobby Jones
Closing the file didn't work.

Closing the file didn't work.  Nor did making it read-only.   I even tried setting the Windows system permissions on the file to "deny write", but it appears to be deleted & re-created.

I also changed all the template rhoconfig.txt files in the main Rho install dir, no luck there either.

Guess I need to force the start location in the app.   Any clues on best practices to wire this up?   I can make it work, I'm sure, but I'd rather do it the "right way" than the "newb way".

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments