Win7 64bit need Installing RhoStudio as an Eclipse Plugin...

Hi,

In order to use RhoStudio with Win7 64bit, the doc says.....  "Installing RhoStudio as an Eclipse Plugin"

http://docs.rhomobile.com/rhodes/rhostudio-eclipse#prerequisites

And followed instruction...

"Check Rhomobile (or RhoStudio) and press Next...."

However, I meet error as below...

Error.jpg

The URL is not working?

Anyone use RhoStudio with Win7 64bit?

Regards.

- Jaehoon -

Evgeny Vovchenko
Use this doc link:http://docs

Use this doc link:

http://docs.rhomobile.com/rhodes/install

If you are running Windows 64-bit, you need to use 32-bit Java when you run RhoStudio. You can include the 32-bit Java in the PATH, or you can run RhoStudio with a link to 32-bit Java:

C:\RhoStudio\eclipse\RhoStudio.exe -vm "<32-bit java path>\bin\javaw.exe"

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jaehoon Lee
Yes. ran as belowC:\>C:

Yes. ran as below

C:\>C:\MotorolaRhoMobileSuite2.0.5\eclipse\RhoStudio.exe -vm C:\Program Files (x86)\Java\jdk1.6.0_32\bin\javaw.exe

But below Error message pop-up.

Error2.jpg

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Robert Galvin
Try putting quotes around the

Try putting quotes around the entire path after the -vm

Sent from my Verizon Wireless 4G LTE DROID

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jaehoon Lee
Tried as below.C:\>C:

Tried as below.

C:\>C:\MotorolaRhoMobileSuite2.0.5\eclipse\RhoStudio.exe -vm "C:\Program Files (x86)\Java\jdk1.6.0_32\bin\javaw.exe"

However same Error message.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Evgeny Vovchenko
Do you have 32-bit java

Do you have 32-bit java installed on your computer ?

C:\Program Files (x86)\Java\jdk1.6.0_32\bin\javaw.exe does it exist ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jaehoon Lee
YES. Of course.As you know,

YES. Of course.

As you know, if you use rhodes-setup it returns "Invalid JDK path"  , I suspect  "("   ")"  in path  .

So I added it via windows-preferrence-RhoMobile.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Chris Misztur
Did you try the latest full

Did you try the latest full installer instead of the plugin?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Patrick Samples
Yes, the fuller installer

Yes, the fuller installer works.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Namitha M
Hi Patrick,  I have installed


Hi Patrick,

 

I have installed RhoMobileSuite2.1.1.7 for Windows 7 to the directory C:\MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.

And I am getting the above mentioned message. So can you help how to solve this !!!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jon Tara
It's not an error message. It

It's not an error message. It's a warning that you can ignore.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Patrick Samples
I have the same issue. I

I have the same issue. I would like to use RhoStudio as a plugin, as I use Eclipse for other development, but I receive the same error. I believe the error is an upgrade problem of not being able to find the url, and not one of using an incorrect variety of java. Can the RhoStudio be upgraded to 2.0, via Eclipse "Check for Updates"? Or must we install a separate RhoStudio version of Eclipse?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Divyansh Madan
I am not really sure if

I am not really sure if "Check for Updates" would work or not,but If you choose to install a separate RhoSutdio version of Eclipse,that would work for sure.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Patrick Samples
Yes, that is the route I

Yes, that is the route I ended up taking. Installing a separate Eclipse version does work, it is just less desirable.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jaehoon Lee
So, current RhoStudio is not

So, current RhoStudio is not working on Win7 64bit correctly, right? 

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Patrick Samples
Jaehoon, I want to clarify


Jaehoon, I want to clarify this. I work on  Windows 7 64 bit, and had RhoStudio installed as an Eclipse plugin version 1.x. Everything worked. I then tried to update the plugin through the Eclipse "check for updates" and received the same error of being unable to find an update at that url (http://rhostudio.rhomobile.com). So, I ended up installing the full RhoStudio, which means I now how two versions of Eclipse installed. With this new installation of RhoStudio, I now DO have the 32 bit version of Java installed, and I am able to develop applications. RhoStudio does work on Windows 7 64 bit.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Evgeny Vovchenko
No. This is not right.Try to

No. This is not right.

Try to change PATH environment variable to 32-bit java bin folder

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments