Your java bin folder does not appear to be on your path.This is required to use rhodes.

How to resolve?

Please refer picture below.

JavaBin.png

Bhakta Ranjan S...
Hi,I believe that your java

Hi,

I believe that your java path is not configured properly.

Go to this location C:\MotorolaRhoMobileSuite2.0.5\ruby\lib\ruby\gems\1.9.1\gems\rhodes-3.3.3

Open rhobuild.yml

Give the path of the java bin folder.

If you are using windows 7 then you need to install 32 bit jdk. (32 bit jdk file looks like jdk-7u4-windows-i586.exe)

And provide your java path java: "C:\Program Files (x86)\Java\jdk1.7.0_04\bin"

I hope this will resolve your problem.

Thanks

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Freddy Chan
Hi,How to add java path

Hi,

How to add java path?

sdkversion: "3.3.3"

name: "rhoelementsapp"

version: "1.0"

vendor: "rhomobile"

build: "debug"

bbver: "4.6"

applog: "rholog.txt"

iphone:

  configuration: "Release"

  sdk: "iphonesimulator5.0"

  provisionprofile:

  codesignidentity:

  entitlements:

  BundleIdentifier: "com.rhomobile.rhoelementsapp"

  BundleURLScheme: "rhoelementsapp"

wp:

  productid: "bdf247c0-982b-012f-119f-4c80930de124"

symbian:

  uid: "0xeed8b968"

android:

  version: "4.0.3"

  emulator: "rhoelementsapp 4.0.3"

extensions:

  - json

  - another-extension

app_type: "rhoelements"

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Bhakta Ranjan S...
Hi,As i have mentioned

Hi,

As i have mentioned earlier you need to mention your java path in rhobuild.yml which is located at this location C:\MotorolaRhoMobileSuite2.0.5\ruby\lib\ruby\gems\1.9.1\gems\rhodes-3.3.3.

The content that you have mentioned here is build.yml content.

Kindly go to the path C:\MotorolaRhoMobileSuite2.0.5\ruby\lib\ruby\gems\1.9.1\gems\rhodes-3.3.3. find the rhobuild.yml file. And mentioned the java path.

Thanks

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Freddy Chan
Hi, Checked, already is java:

Hi,

Checked, already is java: "C:/Program Files (x86)/Java/jdk1.7.0_04/bin"

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
For Windows 7:Start Menu >

For Windows 7:

Start Menu > Control Panel > System > Advanced System Settings.

On the advanced tab, select Environment Variables

In the Environment variables dialog box, select PATH from System Variables box, and select edit.

append a semicolon then the full path to your jdk bin folder, then press OK.

Restart RhoStudio

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Freddy Chan
Thanks bro.Working perfectly.

Thanks bro.

Working perfectly.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
No problem, Glad to help

No problem, Glad to help

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments