Tasks: TOP => run:android:device => device:android:install => device:android:debug => package:android Error in build application

How to resolve?

Please refer the picture below

DX_utility.png

ErrorInBuild.png

Robin West
Two things that helped us

Two things that helped us with this issue:

1) remove the line "app_type: rhoelements" in the build.yml.

2) make sure NONE of your SDK, NDK, or Java paths have a space in it.  Yes, even on the latest build Rho still seems to have issues with this.

For example our Android SDK was in C:\Program Files\Android\blah...    We uninstalled and put it in C:\Android\blah...

Same for the NDK and the Java installs.   The space in "Program Files" seemed to be problematic.   Some things worked, but we never got a clean build each & every time until we moved everything to a no-spaces path.   This includes the Rho install as well.   It was a pain to uninstall & re-install everything to get the spaces out of the path, but we've had no issues related to this on two different dev systems since we made the changes.  

Also, make sure you change your rho config settings to select the new path.   It is in the Eclipse (Rhostudio) project properties.

HTH,

L

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Darryn Campbell
Solution is belowTo use the


Solution is below

To use the android device you need to have this in the build.yml

app_type: rhoelements

capabilities:

- non_motorola_device

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments