Animated "loading" GIF freezes

In some places in our app we use a loading screen while waiting for the results of a webservice.

In it we have this typical animated gif (http://preloaders.net/) to make the user feel like something is happening.

The problem is that this gif's animation freezes a lot of the times. Sometimes it will work flawlessly, sometimes it will freeze a bit before the transition to the next page and other times it freezes the whole time.

We have also tried to animate with javascript through the various images that would conform the animated gif, with similar results.

Evgeny Vovchenko
Looks strange. Do you perform

Looks strange. Do you perform some heavy CPU tasks in background?

What I can suggest is to call Webview.execute_js from time to time to update screen progress

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Daniel López Lacalle
It happens everywhere in the

It happens everywhere in the app in which we use the loading screen. While the screen shows, we call web services and parse (not specially large) xml's. We use rhoxml with a stream parser (we need to support blackberry too...).

We didn't tried to animate using javascript with execute_js, but we did through normal javascript, and the results were similar.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Hi Daniel,We had an issue

Hi Daniel,

We had an issue with Animated gif display a while back though as far as I'm aware it has been resolved in 2.0.5.  Just to confirm, are you using the latest version of the runtime?  2.0.5.27.  Also, I'm guessing this is on Android?  Is this a Rhodes app like your previous post?

Thanks,

Darryn.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Daniel López Lacalle
It is a rhodes app and I'm

It is a rhodes app and I'm using the 3.3.3 version of the gem. Is that what you mean with "version of the runtime"?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
The version I was referring

The version I was referring to was the downloaded version, http://www.motorola.com/Business/US-EN/RhoMobile+Suite/Downloads

Are you using the Motorola or Stock browser?

Thanks,

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Daniel López Lacalle
I have 2.0.5. Don't know if

I have 2.0.5. Don't know if it is exactly a 2.0.5.27, how can I check?

I forgot to tell you before that it is indeed in Android, but it also happens in Blackberry and haven't check in a long time but I'd say in iPhone too.

I guess I'm using the stock browser as I never configured anything to use a motorola browser. I guess this must be a new feature. How can I check?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Thanks for clarifying, I can

Thanks for clarifying, I can't help with this but I'll notify somebody who can.  Thanks.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments