2 Replies Latest reply on Jun 27, 2012 11:16 PM by Oesia Project

    Deleted tables (or whole db?) in terminal

      We have a FixedSchema model. The data is saved in a db table. Sometimes this table is deleted and we don't know why. Sometimes is deleted after a server sync and in the server there are no error. The server sync usually works fine. In our client code there are not any sentence to drop a table.

       

      Why the table is removed?

       

      Thanks,

      Oesia

        • Re: Deleted tables (or whole db?) in terminal

          Table is deleted – you mean table itself or just data from the table ?

           

          When you call reset database , tables recreated

           

           

           

          Can you send application sources and log with MinSeverity=1 ?

            • Re: Deleted tables (or whole db?) in terminal

              Evgeny,

               

              the table itself is deleted, it seems like a "drop table". Our next step is build a basic app with our FixedSchema model and repeat the test. If the issue still occurs then we send you all code and logs. We need to understand what exactly do the sync process. Our model is very simple, one object with 3 fields and, in the server side, an adapter with query function developed to populate @result variable with redis data. We will implement this in the basic sample test. Today is a hard day for us and we hope to do this steps as soon as possible.

               

              Only one question, this issue happens when we do a "dosync" in an admin session. Admin session means that we logged in the server with "admin" login. Is there any problem to use exactly this login? Our first step may be change this user to "oesia_admin" for example.

               

              Another qüestion, we changed the rhoconnect server to be runned like a service. This means it is placed in the nginx/html path and started with the thin process. Before this changes, we ran server from line command "rhoconnect start". Before, in the console did not appear any source, but now, starting server like service, the sources appear. This has something to do with the issue?. We believe that before the tables were not droped and it is possible that this change has something to do. Anyway, we will see it in the basi tests.

               

              Thanks,

              Oesia