4 Replies Latest reply on Jul 6, 2012 5:47 AM by Brandon Headrick

    Can't get Google Voice Search to work

    Brandon Headrick

      I'm trying to integrate voice recognition into my project through a native app.  I'm trying to use google's native voice recognition methods to achieve this.  I wrote a prototype based on this resource: http://www.jameselsey.co.uk/blogs/techblog/android-how-to-implement-voice-recognition-a-nice-easy-tutorial/  

       

      Since I'm not able to use the google market on the ET1 device, I downloaded the google_voice_search_2.1.4 apk from here: http://www.tempfiles.net/download/201202/227429/voice_search_2.html

       

      (note; I have tried 3 versions of google voice search and all 3 fail the same way)

       

      The prototype app works fine on my personal phone, but on the ET1, google voice search crashes when it is accessed (either through the prototype app or just by opening Google Voice Search by itself).

       

      Here is the message that comes up when it crashes: "The application Voice Search (process com.google.android.voicesearch) has stopped unexpectedly.  Please try again."

       

      For the prototype I made sure to build it with minimum sdk compatibility for 2.3.3 and google voice search has a minimum compatability of 2.2.  Furthermore, the prototype resource appears to have been written with 2.3 in mind, though again that shouldn't matter since it's google voice search that fails and not the prototype.

       

      So here are my questions: are there any known issues with the ET1 and google voice search?  If so, how can I address them?  If the solution is to simply install it properly through the google play store, could someone tell me how to set up an account on the device so that I may do this?  I have the google play apk installed, however it wont let me make an account or sign in, so I can't use it at all.

       

      Edit: Dan helped me in a PM suggesting a system restore which solved my problem.

        • Re: Can't get Google Voice Search to work
          Dan Silva

          Brandon,

           

          I downloaded the apk file from the link you provided and it works on my ET1.  I am running the latest OS release (Build number ends in 032812). 

          1 of 1 people found this helpful
            • Re: Can't get Google Voice Search to work
              Brandon Headrick

              This might be my issue; I'm running the build ending with 121411.  Is anyone else on the same build having a similar problem?  At this point I'm trying to nail down whether it's an issue with the device, the OS, or the OS build.

               

              Edit: In addition, is there a way to verify that my build isn't corrupted in any way?

               

              Edit2: I want to update my device, but for the life of me can't find the files to do so.  Does anyone have a link for the latest build download?

                • Re: Can't get Google Voice Search to work
                  Dan Silva

                  If your device is a DV prototye, you will not be able to update past 121411.  If it is a prototype, it will say so on the sticker inside the battery compartment.  That said, I just tried this on a DV device running 121411, and it worked there as well.  Do you have multiuser login and/or applock installed? That might be causing this issue if so.  The OS downloads are on support.symbol.com.

                    • Re: Can't get Google Voice Search to work
                      Brandon Headrick

                      I am running a prototype device.  I don't think I have either of those things installed.  I'm assuming the way I would check is that they would be apps on the actual device, correct?  If that's true, then no, they're not installed.

                       

                      Do you have any other suggestions?  I'd be willing to do a full reinstall if necessary, but I'd prefer not to.

                       

                      Just to note, support.symbol.com has been down for at least 24 hours as of this posting.  If I need to get software from there, are there other resources I can use?