Error in build application

Hi,

I got an error while trying to run my app on USB connected device (ET1). I followed the following process flow -

-> Select the particular Project  -> Run the Project with run as configuration -> select android device mode and -> ok

Please help, If someone can.

A screen-shot of the Error Message is being attched.

Bhakta Ranjan S...
Hi,What's your Build.yml file

Hi,

What's your Build.yml file content ? If you post that here it will be easy to identified the problem.

By default build.yml file contains below part

app_type: rhoelements

android:

  extensions: ["barcode", "rainbow", "nfc", "pdf-writer", "thread"]

  capabilities:

  - network_state

  - sdcard

  - calendar

  #mapping: yes

  version: 2.1

Comment mapping:yes if you dont have any google map API key.

Mention your android version

And build your application.

Try with above build.yml content.

Thanks

Bhakta

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Ariana Habbaba
That error console screen

That error console screen shot you attached doesn't show any errors.

Could you attach multiple screen shots of the entire error console from the moment you started the build?

That way we can get a better idea of exactly what's going on.

Thanks,

Ariana

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Hamid Seleman
The attached error message

The attached error message snapshot gives little information what went wrong. I would suggest you to run rake with --trace flag in the command line as follows:

rake run:android:device --trace

If you're using RhoStudio to perform build, please check "Add --trace to command" checkbox in the Run Configuration.

Hope that helps.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


RANA PRATAP
The problem has been resolved

The problem has been resolved.

Thanks to all.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pavel Machala
Hello everybody,I have

Hello everybody,

I have similar problem. When I want to do device build for ET1 USB device with android, the build stop after 4 minutes with message "Error in build application".

I copied the console log to txt, so you can see it in attachment. Please advice.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
I think your issue is the

I think your issue is the same as the one in this post.

https://developer.motorolasolutions.com/message/3484#3484

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pavel Machala
I would like to build a

I would like to build a sample application: https://github.com/rhomobile/rhodes-system-api-samples but there must be some problem.

I think it should be in build.yml file but I don't know where. Deploy on Windows Mobile platform is all right.

When I create a new Rhomobile project I can deploy it to the ET1 android platform (device build is without any errors).

I have attached content of the build.yml file.

thanks.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Glenn Sayer
It looks like the error you

It looks like the error you are getting is a RhoElements lic error.  Some of the API's require a lic.  Looks like it might the use of encryption.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pavel Machala
I don't know because device

I don't know because device build for Windows Mobile was successful.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Glenn Sayer
Look at this site and as it

Look at this site and as it list the items that need a RhoElements lic for.  One builds and the other doesn't because of what is defined in your build.yml Android an WM are different.

http://docs.rhomobile.com/rhoelements/apicompatibility

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pavel Machala
I set up the PATH earlier,

I set up the PATH earlier, this is another problem definitely.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments