6 Replies Latest reply on Sep 5, 2012 10:47 PM by Nrusingha Charan Patro

    Rhoelements and "Ñ" character



      When we compile our application using Rhoelements the "Ñ" (N-tilde) character disappear.


      Without Rhoelements .> Usuario/Contraseña

      With Rhoelements -> Usuario/Contrasea


      We try using HTML code ñ and ñ, and it doesn't work to. The others special characters like accent work correctly.



        • Re: Rhoelements and "Ñ" character

          try this,  on RhoStudio right click on the page.erb /properties and change the codification  and change the Text file encoding from default to UTF-8

          • Rhoelements and "Ñ" character


            We are using RhoStudio.


            You must write on some *.erb file (our files are UTF-8 file format), for example on the main file index.erb:




            Then you have to built it for Android, first of all using Rhoelements and after it, not using Rhoelements. And you will see that without-Rhoelements works correctly and with-Rhoelements not.





              • Re: Rhoelements and "Ñ" character


                I found a solution for you. In fact there are two ways how to display these characters:


                For both you need to change file Config.xml for your application

                You can find description of setting here http://docs.rhomobile.com/rhoelements/ConfigurationSettings

                You have to change this row:    <FontFamily            VALUE="DroidSans" />  by default I've had there "Droid Sans Fallback" but in my fonts' folder which is located in the  "//system/fonts" was font called "DroidSansFallback". You must look at your android which fonts it supports and what is the correct name in that folder. You should always be sure that chosen font contains characters which you will need. There are only some basic characters by default settings of config.xml this is the reason why your application has got this issue.


                Path to my config.xml file is \\Android\data\com.rhomobile.tilde\config.xml

                For now I am not sure if you can configure config.xml before you deploy application to device so I change the settings after the application was deployed.



                1) when you want to use the HTML code "&#241" or &ntilde you don't need to change default file encoding


                2)I think better way is that you change the file encoding to UTF-8 (right click on eg. "index.erb" in "Project Explorer window", then ->properties->resources->text file encoding). After that check your page you will need to rewrite these special characters in your page if you wrote some of theme before you changed encoding.

                Beauty of this solution is that you don't need to write these terrible codes you can write just what you want "ñ" "Ñ"



                In attachment you can see both solutions realized in my android device:

                -my testing labels were:

                      <li><a href="#">Contraseña</a></li>

                      <li><a href="#">Contrase&#241a </a></li>

                      <li><a href="#">Contrase&ntilde;a</a></li>

                      <li><a href="#">Ñ ñ -- test</a></li>