3 Replies Latest reply on Feb 21, 2013 12:45 PM by John Warren

    Rhodes 3.4.2 const_missing: AppApplication

    Jon Tara

      I tried to build an existing project with Rhodes 3.4.2. (I was successful generating a new application and then building it.)

       

      I went through all the usual conversion steps - set my RVM environment to use the new Gem, rhodes-setup, migrate-rhodes-app, rake switch_app, rake build:iphone:setup_xcode_project, rake run:iphone.

       

      I can't get past the splash screen. I get this in the log:

       

      I 08/31/2012 14:04:25:656 b03d5000           HttpServer| Start HTTP server

      I 08/31/2012 14:04:25:656 b03d5000           HttpServer| Listen for connections on port 62483

      I 08/31/2012 14:04:25:656 b03d5000         AppCallbacks| addCommand: LOCAL-SERVER-STARTED

      I 08/31/2012 14:04:25:657 b0353000         AppCallbacks| process command: LOCAL-SERVER-STARTED

      I 08/31/2012 14:04:25:657 b0353000            RhodesApp| rho_sys_report_app_started has no implementation on iPhone.

      I 08/31/2012 14:04:25:657 b0353000         AppCallbacks| process command: UI-CREATED

      I 08/31/2012 14:04:25:659 b03d5000           HttpServer| Process URI: '/system/uicreated'

      I 08/31/2012 14:04:25:664 b03d5000                  APP| const_missing: AppApplication

      I 08/31/2012 14:04:25:664 b03d5000                  APP| "UI created" callback failed: #<NameError: uninitialized constant AppApplication>;Trace: lib/rho/rho.rb:1374:in `const_missing'

      lib/rho/rho.rb:216:in `const_get'

      lib/rho/rho.rb:216:in `get_app'

      lib/rho/rho.rb:175:in `ui_created'

      I 08/31/2012 14:04:25:665 b0353000         AppCallbacks| process command: APP-ACTIVATED

        • Re: Rhodes 3.4.2 const_missing: AppApplication
          Jon Tara

          And this:

           

          I 08/31/2012 14:35:54:675 b04d9000                  APP| Application initialize failed: #<NoMethodError: undefined method `new' for RhoLog:Module>;Trace: apps/app/xmpp/client.rb:20:in `<class:Client>'

          apps/app/xmpp/client.rb:17:in `<main>'

          apps/app/application.rb:2:in `require'

          apps/app/application.rb:2:in `<main>'

          lib/rho/rho.rb:214:in `require'

          lib/rho/rho.rb:214:in `get_app'

          lib/rho/rho.rb:127:in `init_app'

          I 08/31/2012 14:35:54:675 b04d9000           HttpServer| Start HTTP server