MC70 GPRS Comms whilst in 4-slot cradle

Team,

My customer has standardized on BSP39 for their MC70's. 
They only use the WAN (no WLAN). 

All is fine, but when they put it in the 4-slot cradle for charging, the USB Comms takes priority. 
Hence no WAN comms are possible whilst it's in the cradle. 
As soon as they take it back out of the cradle - WAN goes back to normal.

Is there any way of overriding this so they can continue with uploads/downloads through their WAN connection whilst it is in the cradle?

Note: They don't need to active Sync when cradled. All they do is dock it for charging. 
Gene Niles
using wincloser or hitting

using wincloser or hitting the cancel button is really a work-around. Underlying reasons for this have included DLL crunch and cradle debounce.
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Richard Linsley-Hood
You should be able to disable

You should be able to disable ActiveSync (including the Ethernet cradle) from connecting by changing a registry setting on the device. Change AutoCnct (see below) to 0.You would then require to start ActiveSync on the device maually if you wish to use it subsequently.

From the MSDN.

Device Registry Settings for ActiveSync
http://msdn.microsoft.com/en-us/library/aa914986.aspx




The registry settings related to ActiveSync connectivity are stored under the HKEY_CURRENT_USER\ControlPanel\Comm registry key on the target device.


The following table lists the registry values for the HKEY_CURRENT_USER\ControlPanel\Comm registry key.












Value : type Description

AutoCnct : DWORD


Default setting is 1 (on). This value turns Autoconnect on and off.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Serge Larose
HI, I have the same problem

HI,
I have the same problem and I used Wincloser.
The customer is using Wincloser for more then a year and it resolve the problem.
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Alarico De Zotti
Active sync connection is not

Active sync connection is not related with the issue that you see,
is the connection manager that find another network connection and stop using the GPRS one.
In order to avoid this the best solution that I found is remove or replace the driver for usblan with a fake one \Windows\LANUSB.dll  after that if you insert a terminal in a 4 slot ethernet cradle the terminal ask you for a suitable driver for the new usb device found. I use winclose to kill this pop up. My suggestion is also to made a grip request in order to have a hardware switch on the 4 slot ethernet cradle to disable or enable communication part or better a firmaware that understand that the ethernet port are down so not enable the communication part  (so let use the cradle only for charging). 

Alarico
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Gene Niles
ignore my last posting. I

ignore my last posting. I thought it was related to a USB not found topic.
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Allan Herrod
Let's make sure we are all

Let's make sure we are all talking about the same issue here.  As I understand it, the issue is that both the Ethernet Cradle connection and the WWAN connection exist and Windows is choosing the Ethernet Cradle connection over the WWAN connection.  This is normal and expected IF there is a valid Ethernet Cradle connection since Windows will consider it a "better" connection.  There are APIs in the IpHelper group that can be used to adjust the routing table to manually control which adapter will be used for certain destinations, but they are a royal pain to use.  Short of that, the only way to ensure that Windows won't use the Ethernet Cradle connection instead of the WWAN connection is to make sure the Ethernet Cradle connection is not established.  That is the gist of the ideas that have been discussed where the driver for the Ethernet Cradle connection is removed or replaced and logic to get rid of the resulting popup (e.g. Wincloser) is used.  While I would generally not recommend such an approach, it likely could be made to work.  But it also means that the Ethernet Cradle connection could never be used.
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Ian Jobson
The easiest way to avoid this

The easiest way to avoid this without having to have wincloser running in the background taking up resources is to make sure the GPRS (or WLAN) radio has the best route in the WM connection manager.

The USB / ethernet connection is set to DHCP by default, if it doesn't get a DHCP address it will use the in built 169.x.x.x address which is seen by WM as a valid route with a lower cost than the WWAN or WLAN.

However, if you disable DHCP on the USB / Ethernet connection and give it an IP address of 0.0.0.0 then it will be an invalid route in connection manager and therefore won't be used.

The following registry key should work, but if it doesn't it will give you the jist!


[HKEY_LOCAL_MACHINE\Comm\LANNDS1\Parms\TcpIp]
"DefaultGateway"=""
"EnableDHCP"=dword:00000000
"IpAddress"="0.0.0.0"
"Subnetmask"="0.0.0.0"
"UseZeroBroadcast"=dword:00000000


IJ
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Herbert De Jong
Here is the registry


Here is the registry information that should mean that the USB ETHERNET DRIVER fails to load Works on MC70 MC75.


REGEDIT4


[HKEY_LOCAL_MACHINE\Comm\LANNDS1\Parms\Tcpip]


"EnableDHCP"=dword:0


"DefaultGateway"=""


"UseZeroBroadcast"=dword:0


"IpAddress"="127.0.0.1"


"Subnetmask"="0.0.0.0"


[HKEY_LOCAL_MACHINE\Comm\NdisPower]


"LANNDS1" = dword:00000004

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Richard Linsley-Hood
Allan/All, If you use the

Allan/All,

If you use the registry setting I provided ( AutoCnct) then ethernet connections, cradle, etc. will continue to work as normal but only if ActiveSync is started manually on the device.

Richard LH
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Allan Herrod
Richard; Unless I

Richard;

Unless I misunderstand, ActiveSync settings have no relevance to the Ethernet Cradle operation.

Allan
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Richard Linsley-Hood
I forgot to mentions, it is

I forgot to mentions, it is the triggering of ActiveSync IP/PPP on the device by USB detection that causes the routing table to be altered to include the route that is then established.

No ActiveSync - no ip address for the USB PPP adapter - no routing table changes.

Richard LH
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Allan Herrod
Let me clear a few things up


Let me clear a few things up here.
There are two styles of cradle in use USB and Ethernet.

USB cradles provide a connection between a device and a PC running ActiveSync and require a PPP connection between the ActiveSync software on the device and the ActiveSync software on the PC to obtain network connectivity for the device.

Ethernet cradles use a different approach since no PC running ActiveSync is involved and the ActiveSync software on the device is never used.  Instead, the cradles bridge the device directly onto the Ethernet backbone.

For client-mode Ethernet cradles, which is basically just the MC9XXX series, a special software module (eConnect or iDockIt) is required on the device to establish the connection to the cradle.  This software module configures the PPP connection and handles the routing.  ActiveSync is not involved.

For host-mode Ethernet cradles, which is basically everything EXCEPT the MC9XXX series, no special software is required since the drivers are built-in.  A network connection is established with the USB-to-Ethernet adapter in the cradle via Remote NDIS (RNDIS).  Again, ActiveSync is not involved.

So, if you plan to "solve" the issue by preventing the Ethernet cradle connection from being established, you need to prevent Connection Manager from seeing the Ethernet cradle as a "better" route than WWAN.  This can be done by preventing the connection (by removing or replacing the drivers), by preventing valid IP address assignment, etc.  It cannot be done by changing the configuration of ActiveSync since ActiveSync is not involved.


Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Harry Banias
All, Thanks for your input.

All,

Thanks for your input. Some good info there.
I'll do some testing laster today.

However just to add something further to this......can anyone explain why it works with BSP21?
(I know that's going back a bit - but that's how the customer came across this issue in the first place. They had standarized on 21 and now have moved to 39).

So I guess there would have some reg setting in place originally to allow this WAN whilst cradled and then taken out with later releases.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Alan Livingston
You can change the network

You can change the network adapter metric with a simple registry file.  Since you want to maintain GPRS connection, the key is to keep your GPRS adapter metric less than the wired metric, as Allan Herrod stated.

I'm not sure what the 4 slot ethernet metric is, but the GPRS metric is 50.  I'd start reducing the metric until it works, perhaps 5 at a time.

The registry key contains the name of the Connection you created in Connection Manager.  For example, I created a connection named "Cingular Line" and here's the registry key I would use to set my metric to 35 (it's hex):

[HKEY_LOCAL_MACHINE\Comm\Cellular Line\Parms\TcpIp]
"InterfaceMetric"=dword:00000023

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments