0 Replies Latest reply on Oct 9, 2012 10:09 PM by Maksym Grebenets

    RhoRuby| require_compiled: error: can not find rhodes_translator (Mac OS X)

      Hi.

       

      I am trying to run my custom project in RhoSimulator and face this error:

      RhoRuby| require_compiled: error: can not find rhodes_translator

       

      The launch image shows up in simulator and that's it.

      The error does not occur with sample application, I am able to run in in simulators and on devices.

       

      I followed all installation instructions (version 2.1), starting with RVM, then 'Install gems', then run RhoStudio.

      Running 'gem list' shows a list of rhodes gems installed:

      *** LOCAL GEMS ***

       

       

      rhoconnect (3.3.2)

      rhoconnect-adapters (1.0.5)

      rhodes (3.4.2)

      rhodes-translator (0.0.4)

      rhoelements (2.1.1.7.0)

      rhohub (1.0)

      rhomobile-debug (1.0.6)

       

      Ruby version is correct as well

      splash@splashs-Mac-Pro[~/.rvm/gems/ruby-1.9.3-p194/gems/rhodes-3.4.2]$ ruby -v

      ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.4.2]

       

      I tried adding

      - rhodes_translator

      to build.yml, it didn't help, I even tried rhodes-translator and other combinations, still nothing.

       

      The very same project builds and rund on Windows machine, but not on Mac running Mac OS X 10.7.5 (Lion)

       

      JDK is up to date

      java version "1.6.0_35"

      Java(TM) SE Runtime Environment (build 1.6.0_35-b10-428-11M3811)

      Java HotSpot(TM) 64-Bit Server VM (build 20.10-b01-428, mixed mode)