Java for CE

Does anyone know, or have used a Java client for our Mobile Devices? I know that in the past we had a relationship with NSIcom for Creme Plus, however I'm led to believe we no longer have links into them anymore. Lookign to usewith MC9090 and VC5090.
Any feedback or thoughts would be appreciated.
Thanks
Justin
Anonymous (not verified)
Prasanth, I've used the IBM

Prasanth,

I've used the IBM J9 Runtime on MC7094's and MC7594's.  Close enough to a MC9090 that I can probably answer any questions pertaining to the J9 runtime that you might have.  Send me an email with any questions and I'll see what I can do.
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Prashanth Kadur
We support IBM J9 and NSICom

We support IBM J9 and NSICom Creme JVMs on several MCD products including MC9090 and VC5090. The following link describes the Installation Requirements for using these JVMs:
http://support.symbol.com/support/search.do?cmd=displayKC&docType=kc&externalId=12329&sliceId=&dialogID=110384159&stateId=1%200%20110378783

Please note NSICom's Creme Plus is no longer supported.
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Mario Guillen
Dave,How does one get the IBM

Dave,

How does one get the IBM J9 JVM?  Is there a license fee?

Mario
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Prashanth Kadur
Mario, Soon Motorola will be

Mario,

Soon Motorola will be reselling the J9 for MC75 devices. Please contact Paul Seiter for information.
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Marc Fluhrer
We are trying to use IBM Host

We are trying to use IBM Host on Demand (which seems to be a WebSphere product) with the VC5090 and it requires a runtime. I do not know what the difference is between J9 and Java ME, but the IBM Java website does not have the VC5090 listed as an approved device.

Has anyone used the IBM WebSphere Everyplace Micro Environment for WinCE 5.0 Personal Profile 1.1 on a VC5090? The customer is hesitent to spend the $25 for the license.

Thanks.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Prashanth Kadur
Marc, WEME and J9 are the

Marc,

WEME and J9 are the same product.

VC5090 is approved for use with WEME for CE 5.0 Personal Profile (PPRO) 1.0.  However, we found no issues with using PPRO1.1 during our internal Engineering testing.  If there is a need for offically supporting PPRO1.1, please create a GRIP request. 

I can't tell you why IBM does not list 5090 as a supported device but we support WEME PPRO1.0 on VC5090.
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Anonymous (not verified)
Hi, We have like 3000 MC3090

Hi,
We have like 3000 MC3090's actually running in Correos Argentinos and they needed more terminals, so they think to buy some MC3190's.
The problem is that their application is in Java running with J9 and want to certify it works with WinCE6.0
What can we recommend to ensure correct behaviour while minimizing migration cost impact?

Regards,
Gustavo,
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Prashanth Kadur
Gustavo, The J9 JVM

Gustavo,

The J9 JVM provided by IBM does not support CE6.0.  As a matter of fact, the J9 support is now limited to a handful of Motorola devices running Windows Mobile.  The only JVM supported by EMDK on MC3100 CE6.0 is NSICom's Creme.  I can't really assess the effort required for migrating from J9 to Creme.  It all depends on the application and what they are doing in it.

- Prashanth
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Thanks Prashant, I have

Thanks Prashant, I have recommended NSICom JVM.
Now customer says it's having problems.
They installed NSICom CrE-ME JVM (Rev. 4.12)  with CrE-ME412_ARM_CE50_HPC.CAB.
Also installed Motorola EMDK for Java v2.4 SDK cabs "symbol.java.arm.cab" and "symbol.jsamples.arm.cab"
But trying to execute some example they get "Application CrEme.exe encountered a serious error and must shut down."

Question is if they are using the right JVM version.

Regards,
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Prashanth Kadur
Gustavo, We have validated

Gustavo,

We have validated the " CrE-ME412_ARM_CE60_HPC.CAB" JVM from NSICom.  This is the JVM recommended by NSICom for CE6.0.  NSICom had promised to make this JVM available on their website, but they have not done that so far.

The customer should contact NSICom for a copy of this JVM.
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Juan-Antonio Ma...
Is this version valid for WM6

Is this version valid for WM6.5 too?
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Prashanth Kadur
No, According to NSICom, you

No, According to NSICom, you cannot use  CrE-ME412_ARM_CE60_HPC.CAB on WM6.5.x devices.  Here are the validated Creme JVMs as documented in the EMDK ReadMe:

Following are the CrE-ME JVM installation packages validated with EMDK for Java.

  • Windows Mobile 6.5 platform is validated with CrE-ME412.26_ARM_CE42_PPC_W7.exe (Windows7 compatible)

  • Windows Mobile 6.0/6.1 platform is validated with CrE-ME412[1].22oa_ARM_CE61_PPC.exe

  • Windows Mobile 5.0 platform is validated with CrE-ME412[1].22_ARM_CE42_PPC.exe

  • Windows CE 5.0 platform is validated with CrE-ME412_ARM_CE50_HPC.exe

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments