9 Replies Latest reply on Nov 14, 2012 11:34 PM by Nrusingha Charan Patro

    struggling to start with rhomobile

      Hi,

       

      I am new to Rhomobile,struggling to start with..

      Is there any guide to follow for installation and execution of any samples for various mobile such as blackberry,android and windows phone.

      It would be very useful for me to jump into rhomobile...Thanks in advance

        • Re: struggling to start with rhomobile

          Hi,

          Thanks for your reply,tried to build for BB as specified in the above link.

          In Rhostudio modified the build.yml as given below:

           

             name: "rhodes-system-api-samples"

          #app_type: rhoelements

          capabilities:

            - gps

            - pim

            - camera

            - vibrate

            - phone

            - bluetooth

            - calendar

          bbver: "6.0"

          #- native_browser

          #- motorola_browser

          applog: "rholog.txt"

          version: "1.0.7"

          #sdk: c:/Projects/rhodes

          vendor: "rhomobile"

          iphone:

            emulator: 5.0

            sdk: "iphonesimulator5.1"

            codesignidentity:

            entitlements:

            extensions:

              - barcode

              - rainbow

              - digest

              - digest-md5

              - digest-sha1

              - pdf-writer

              - thread

              - nlist

              - digest-sha2

              - openssl.so

              - openssl

              - ezcrypto

          #buildcfg: 'Debug'

              - rawsensors

            entitlements_file: "./production/Entitlements.plist"

            configuration: "Debug"

          #"rainbow"

          #sdk: "MC3000c50b (ARMV4I)"

            production:

          #sdk: "Windows Mobile 6.5.3 Professional DTK (ARMV4I)"

          #emulator: "Windows Mobile 6.5.3 Professional Emulator"

          #use_shared_runtime: 1

              app_plist_title: "SAS"

              app_plist_subtitle: "SAS"

              app_plist_icon_url: "www.sas.com/icon.png"

              app_plist_ipa_url: "www.sas.com/sas.ipa"

              ipa_itunesartwork_image: "./production/image.jpg"

          wm:

            extensions:

              - digest

              - digest-md5

              - digest-sha1

              - digest-sha2

              - openssl.so

              - openssl

              - ezcrypto

            sdk: "Windows Mobile 6 Professional SDK (ARMV4I)"

          win32:

            extensions:

              - digest

              - digest-md5

              - digest-sha1

              - digest-sha2

              - openssl.so

              - openssl

              - ezcrypto

          bb:

            extensions:

              - barcode

            bbver: 7.0

          android:

            extensions:

              - barcode

              - rainbow

              - nfc

              - digest

              - digest-md5

              - digest-sha1

              - pdf-writer

              - thread

              - digest-sha2

              - openssl.so

              - openssl

              - ezcrypto

              - rawsensors

            capabilities:

              - network_state

              - sdcard

              - calendar

            mapping: true

            version: "4.0.3"

            emulator: "And"

          wp7:

            productid: "fd55c4d0-51fa-012e-7844-3caec51bd50e"

            env:

              paths:

                msbuild: "C:/Windows/Microsoft.NET/Framework/v4.0.30319"

                vcbuild: msbuild

          extensions:

            - json

            - rhoxml

            - rhodes_translator

          symbian:

            uid: 3780829575

          excludedirs:

            bb:

              - "**/*.mp4"

            bb6:

              - "**/*.mp4"

          build:

            bbsignpwd: asdf1234  

           

          but It throws failed signing  with incorrect password.

           

          Thanks.

          • Re: struggling to start with rhomobile

            Hi,

             

            Any updates for the above blackberry issue?

             

            Now i am facing  another issue,but this is for windows phone - it throws an error stating that it couldn't find msbuild folder...(uploaded build.yml in previous post)

             

            Please help me.

             

            Thanks in advance.

            • Re: struggling to start with rhomobile

              Hi,

              Thanks for your reply,The app got signed and need to deploy it in device,Thank you once again.

               

              Now i i am facing another issue with windows phone 7 build error:

              PWD: C:/MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/gems/1.9.1/gems/rhodes-3.4.2/platform/wp7

              CMD: msbuild rhodes.sln /property:Configuration=Release

              rake aborted!

              No such file or directory - msbuild

               

              Tasks: TOP => device:wp:production => build:wp:rhodes

              (See full trace by running task with --trace) 

               

              this is the error i am getting when i try to build for windows phone 7 simulator.

                In Rhostudio modified the Rhobuild.yml as given below:

               

                 env:

                app: "C:/rhodes-app"

                paths:

                  java: "C:/jdk1.6.0/bin"

                  android: "C:/Program Files/Android/android-sdk"

                  android-ndk: "C:/android-ndk-r8b"

                  cabwiz: "C:/Program Files/Windows Mobile 6 SDK/Tools/CabWiz"

                  4.6:

                    jde: "C:/Program Files/Research In Motion/BlackBerry WebWorks SDK 2.3.1.5/simpack/7.0.0.318"

                    mds: "C:/Program Files/Research In Motion/BlackBerry WebWorks SDK 2.3.1.5/mds"

                    sim: 9300

                  4.2:

                    jde: "C:/Program Files/Research In Motion/BlackBerry Smartphone Simulators 7.1.0/7.1.0.219 (9360-Bell)"

                    mds: "C:/Program Files/Research In Motion/BlackBerry JDE 7.1.0/MDS"

                    sim: 8100

                  vcbuild: "C:/Windows/Microsoft.NET/Framework/v4.0.30319/msbuild.exe"

                  6.0:

                    jde: "C:/Program Files/Research In Motion/BlackBerry JDE 7.1.0"

                    mds: "C:/Program Files/Research In Motion/BlackBerry JDE 7.1.0/MDS"

                    sim: 9900

              build:

                bbpath: "platform/bb"

                wmpath: "platform/wm"

                wppath: "platform/wp7"

                androidpath: "platform/android"

              # Google API key obtained from http://code.google.com/intl/en/android/add-ons/google-apis/mapkey.html

              #apikey: "GOOGLE-API-KEY-FOR-ANDROID"

              # This is version of Android platform used to run emulator. If not specified, latest available will be used.

              #version: 1.6

              # This enable/disable native geo mapping for Android. Disabled by default

              #mapping: yes

              # Here data for production certificate located. If file pointed by certificate: does not exist, it will be auto-generated

              #production:

              #  certificate: /path/to/developer/certificate

              #  password: "password-for-certificate"

              #  alias: "certificate-alias"

                iphonepath: "platform/iphone"

                symbianpath: "platform/symbian"

                bb:

                bbsignpwd: "asdf1234"

              android:

              excludedirs:

                all:

                  - "**/.*.swo"

                  - "**/.*.swn"

                  - "**/.DS_Store"

                bb:

                  - public/js/iui

                  - "public/js/jquery*"

                  - "public/jqtouch*"

                  - "public/js/prototype*"

                  - "public/css/iphone*"

                  - public/iwebkit

                  - public/themes

                  - "**/jquery*.js"

                  - "**/*.db"

                  - public/images/android

                  - public/images/iphone

               

              Please help me.

               

              Thanks in advance.

               

               

              • Re: struggling to start with rhomobile

                Hi Team,

                I downloaded rhomobile-rhodes-system-api-samples(from github) and deployed in android and blackberry devices.The barcode scanner works fine in android device but it gives an empty message for blackberry device.My doubt is that am i missing any configuration for blackberry becoz the same code works fine for android.Please guide me.

                 

                Thanks in advance.