Instant Rhodes for MAC OS

Hi,

Is it required Instant Rhodes to develop iPhone application on MAC OS X 10.7 system ?

If yes, then please share URL to download Instant Rhodes for MAC OS.

Please help it.

Thanks in Advance.

Jon Tara
I think that "Instant Rhodes"

I think that "Instant Rhodes" is just a *very* old name for the RhoStudio installer.

Just follow the installation instructions from the latest documentation, and ignore whatever old documentation you are getting this from.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
Hi Jon,Thanks for reply.Could

Hi Jon,

Thanks for reply.

Could you please share the suitable version of RhoStudio installer for MAC OS ?

And from where it is downloadable ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Bhakta Ranjan S...
Hi,The .dmg file available
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
Hi Bhakta,Thanks for reply

Hi Bhakta,

Thanks for reply.

There is need to install RVM (Ruby Version Manager) before installing RhoMobile Suite and then Ruby version 1.9.3.

Could you please share the details how to install and where is this available ?

Please help it.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jon Tara
Have you heard of Google?Try

Have you heard of Google?

Try it.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
...Actually i am following

...

Actually i am following below link:

https://rvm.io/rvm/install/

But its not working

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Bhakta Ranjan S...
Hi,Try the following

Hi,

Try the following command

bash -s master < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer)

And no need to worry about Ruby (MAC is having ruby by default), RhoMobileSuite(.dmg) contains the files that will add all the gems.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
Hi,Thanks for reply.I used

Hi,

Thanks for reply.

I used above link as below:

Now run "Install gems"  as:

Still getting same. Pls help, as i am new user.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Bhakta Ranjan S...
HI,RVM is not installed ,

HI,

RVM is not installed , from the 1st screenshot its cleared.

I think your system has proxy enabled network connection. Connect your laptop to a non proxy enabled network and try again.

Thanks

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
Hi,Many Thanks for your help.

Hi,

Many Thanks for your help.

After run "Install gems" as:

Getting errors as above.

What should i do ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Bhakta Ranjan S...
Hi,Hit y rather than N . "Do

Hi,

Hit y rather than N .

"Do you want to install gems with 'sudo' command prefix?[yN]" y

Thanks

Bhakta

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
Hi Bhakta,Which password is

Hi Bhakta,

Which password is required now ?

Thanks...

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Bhakta Ranjan S...
Hi,Sudo command needs your

Hi,

Sudo command needs your system password. (MAC login password)

Thanks

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
Hi Bhakta,Entered password

Hi Bhakta,

Entered password but again getting error as:

Is there any version issue ?

Thanks.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jon Tara
A few errors during the build

A few errors during the build of documentation are normal for Gem installation. This is nothing to be concerned about.

However, I do not recommend installing RhoElements in system directories as you have above. Install rvm and learn how to use it. As a practical matter, anybody doing any kind of Ruby development today has to learn rvm and use it to manage multiple versions of both Ruby and Gems.

And, while Mac has built-in Ruby, the built-in Ruby is not optimal for RhoElements. It is a very old version.

When you do install rvm, there are two options: to install in system directories or install in user directory. Install in user directory! It is too much trouble to install in system directory, especially when doing Gem updates, and it really is not conventional to install rvm in system directories.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pratik Munjal
HiCould u please suggest how

Hi

Could u please suggest how to install Gems ?

I tried a solution as below:

" Start XCode. Go to menu "XCode"->"Preferences". Open "Downloads" then "Components". Find "Command Line Tools" in list of components. Is it installed? If not then install it and try install gems again. "

But not getting "Command Line Tools" in list of components.

Please help.

Thanks.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments