2 Replies Latest reply on Dec 5, 2012 11:38 AM by Peter Arcuri

    redis won't start up

    Peter Arcuri

      I created a quick demo rhoelements and associating rhoconnect app. When I go to start redis (rhoconnect redis-start) within the project workspace I get a message that redis is starting in another window, yet no window launches hence rhoconnect will not start. I have RMS2.1 installed on C\drive and project workspace is in D\drive for Windows 7 64bit. However, when I run the same app on my WinXP machine i'm able to start redis and subsequently rhoconnect server.

       

      My workaround to getting redis started on my Win7 workstation is to modify the redis.bat that simply contains:

      C:\MotorolaRhoMobileSuite2.1.1.7\redis-2.4.0\redis-server C:\MotorolaRhoMobileSuite2.1.1.7\redis-2.4.0\redis.conf

       

      File originated from C:\MotorolaRhoMobileSuite2.1.1.7\redis-2.4.0\redis.bat

       

      I call the modified redis.bat file directly without the rhoconnect prefix. Naturally this bypasses RhoConnect and although my app connects and sync's fine, I'm uncertain if other issues may arise.

       

      Anyone come across this unusual behavior?

        • Re: redis won't start up

          At start-up time  'rhoconnect start' command checks only presence of redis service by pinging it (host and port are defined in setting.yaml file). You can start redis-server as s service and forget about it for awhile. Only matters host and port values in yaml file. They should match settings of running redis server.

           

          Apparently, you encountered limitations of rhoconnect resdis-start command. It assumes default location of redis at

          "C:/". You can redefine it by setting env. variable 'REDIS_HOME' to "D:/"

            • Re: redis won't start up
              Peter Arcuri

              Hi Alex, thanks for the insight... based on my setup/environment I had to enter the entire path for the REDIS_HOME variable... as shown below:

               

              C:\MotorolaRhoMobileSuite2.1.1.7\redis-2.4.0

               

              It works now!!!

               

              Not to dwell on this issue of spanning across multiple drives, but I tried moving my Rho app pojects (workspace) to C drive so that everything is running off of the same drive... it rendered the same unfavorable results. The fact that Rhoconnect commad file was unable to find redis is unsual expecially when the redis path noted above was already in my System Path.

               

              Anyway, the addition of REDIS_HOME variable did the trick.

               

              It would be helpful to add this tidbit to docs.... cheers and thanks again!