4 Replies Latest reply on Dec 12, 2012 9:51 AM by RAMA RAJU UPPALAPATI

    How to access RhoElements application in Motorola device

      We have tried to build the RhoElements application for Motorola Windows Mobile devices but its failing. We need help to resolve this issue.

       

      We have done the following steps:

      1. 1.      We had added the following 2 line in rhobuild.yml under paths:

       

      env:

      app: C:/rhodes-app

      paths:

       

      vcbuild: C:/Program Files/Microsoft Visual Studio 9.0/VC/vcpackages/vcbuild.exe

      cabwiz: C:/Program Files/Microsoft Visual Studio 9.0/SmartDevices/SDK/SDKTools/

       

      1. 2.      We had added the following in the build.yml

      wm:

      use_shared_runtime: true

       

      unselect non-motorola device and select motorola browser

       

      1. 3.      We create a run configuration in RhoStudio, choose Windows Mobile as the platform, and click the Run button. We have noticed the following in the RhoStudio consol

       

       

      cd C:/RU96965/DocServices/MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/gems/1.9.1/gems/rhodes-3.4.2

      ** Execute run:wm:device

      ERROR: The process "detool.exe" not found.

      cd C:/RU96965/DocServices/MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/gems/1.9.1/gems/rhodes-3.4.2/res/build-tools

      Microsoft (R) Windows Script Host Version 5.7

      Copyright (C) Microsoft Corporation. All rights reserved.

       

       

      Starting application on the device

      Please, connect you device via ActiveSync.

       

      EXC: No connection could be made because the target machine actively refused it. - connect(2)

      RhoLogServer is starting

       

      …………

       

      RET: Starting application...\Program Files\RhoElements\RhoElements.exe -approot='\Program Files\InventoryManagement'

      RET: CreateProcess failed with Errorcode = 2

      RET: FAILED

      RET: 0

       

      PWD: C:\RU96965\DocServices\rhoelementstutorial-master\InventoryManagement

      CMD: rake run:wm:get_log

       

      1. 4.      After this we have noticed that our application was deployed on the device through ActiveSyn. We are not aware how to configure our RhoElements application (.erb) in config.xml file.
      2. 5.      Then we install the .cab file of our application on the device. When we tried to launch the application it is giving the following message “The File ‘RhoElements’ cannot be opened. Either it is not signed with a trusted certificate, or one of its components cannot be found. If the problem persists, try reinstalling or restoring the file.”

       

      Please do the needful.