13 Replies Latest reply on Jan 10, 2013 4:32 AM by Stanislav Volodarskiy

    RhoStudio shows error on line 1 of every ERB

    Jon Tara

      Fresh install of RhoStudio 2.0.0.201211162252 on OSX.

       

      It erroneously shows an error on line one of every ERB file, underlining the first letter of the first HTML tag. (e.g. <div data-role="page"> underlines the "d" in "div").

       

      Application builds fine, but this makes it difficult to locate actual errors in the project, since you cannot rely on the red "X"s in the project explorer to be meaningful.

        • Re: RhoStudio shows error on line 1 of every ERB
          Hector Meza

          Jon, you mention Rho 2.0 is what you installed - what version did you have before the fresh install?

           

          Did you un-install the older version of Rho, I am assuming a clean install would imply that you did but just in case you did not, it should be done.

           

          Is the project you are working with a new project? -- Also, I would suggest you un-install all previous version and install the latest Rho 2.2 that was reciently released.  I would then create a new project with 2.2 and see if the error still exist.

           

          HM

            • Re: RhoStudio shows error on line 1 of every ERB
              Jon Tara

              I have the plugin version of RhoStudio (1.3.1) installed in Eclipse 3.7 Indigo. I cannot uninstall this, as I use Eclipse for other, non-Rhodes projects, and also need this to support work for clients on older versions of Rhodes.

               

              I will not let the tail wag the dog.

               

              I think I should just stop using RhoStudio, as increasingly it brings nothing (but trouble) to the table for me.

               

              I already do most of my work in Sublime Text 2. I use Eclipse for some git operations, because egit is friendlier than command-line, and there is not as yet a Sublime Text 2 git bundle that is as powerful as egit. As well, I still use Eclipse for file and structural compare when I want to see what has changed between versions. I build in command-line and certainly could create apps and model on command-line easily, so not sure why I actually need RhoStudio any more.

               

              Personally, I'd rather RhoMobile put some resources on a Sublime Text 2 bundle, rather than continue to flog this dead horse that does not conform to the Eclipse plugin philosophy.

               

              There should be no reason to have to uninstall the older version of RhoStudio. It is just a customized Eclipse with RhoMobile plugins, and each installation of Eclipse should stand alone, and there is no reason why multiple versions of Eclipse cannot live on the same system. It is just a directory of code that one loads with Java. (Or should be! If not, let me know what I need to clean up...)

               

              I only installed RhoStudio because I had hoped that it at least now used Eclipse 4.2 Juno, as egit is much better in Juno. I would have reluctantly made it my base Eclipse installation, and added all of the other plugins I normally use. But I see it is still using Indigo, and so I see no reason to continue to use it at all.

               

              The project I tested this on is a brand new project. I created a project called Test351. It's my standard procedure when I install a new version of Rhodes and try it out, and then update projects. I create a default project, add a simple model ("fruit") and then compare with the previous test project to see what if anything I have to change. (Since RhoMobile offers no guidance on how to go about updating from one version to the next.)

               

              Eclipse is useful to me when I do this, because I can use the structure compare to quickly see what files are different between the two projects. I think now that an Eclipse installation that does not include RhoStudio will do this job better for me.

               

              I had to run RhoStudio from the command line, after first setting RVM gemset. This is as I have done in the past. I had thought that RhoStudio now had some kind of rvm support built-in, but if it is there, I cannot find it. It will not even use my default gemset - it seems to always use the global gemset (when not started from command-line) even if I have a default set.

                • Re: RhoStudio shows error on line 1 of every ERB
                  Jon Tara

                  Well, this seems not to be a RhoStudio problem, per se.

                   

                  This happens in generic Eclipse, as well. I went ahead and installed Eclipse Juno, and I get the same error there as well (with DLTK Ruby).

                   

                  However, I only get this on the project I just recently generated. I do not get this error in existing projects. I'm thinking it could be a character set issue, but removing and replacing the text doesn't help.

                   

                  A bit more information on the error, it's:

                   

                    syntax error, unexpected tLT.

                   

                  I get this on the opening tag of every ERB file.  e.g. if the ERB file starts with <div, then I get this error with the "d" in "div" flagged.

                   

                  So, it doesn't seem to be anything about the file itself. I'm guessing that there is some difference between the Settings for the new project vs. my older projects that don't get this error.

                    • Re: RhoStudio shows error on line 1 of every ERB
                      Jon Tara

                      Tried generating a project by command-line, doesn't help.

                       

                      Tried generating an app with 3.4.2, gets the same error. Ditto with 3.3.3.

                       

                      Only thing I have isolated is that existing projects are fine, new projects are not.

                       

                      I'm thinking that I must have previously disabled some syntax checking, and need to do so in the new project as well.

                       

                      Don't get any idea what "unexpected tLT" means from web searches. Assume it means unexpected <, but I don't get why < would be unexpected as the first character of an ERB...

                • Re: RhoStudio shows error on line 1 of every ERB

                  What is version of DLTK Eclipse plugin?

                    • Re: RhoStudio shows error on line 1 of every ERB
                      Jon Tara

                      It doesn't seem to be dependant on the version of DLTK, but only if the app is newly-generated or not. It doesn't even depend on the version of Rhodes (at least back to 3.33) it is very strange indeed.

                       

                      I've tested with:

                       

                      - Eclipse 3.7 Indigo with RhoStudio plugin 1.3.1 (has DLTK 2.0 included in RhoStudio)

                       

                      - RhoStudio 2.0.0.201211162253 (has DLTK 4.0 included in RhoStudio)

                      Numbering is confusing, this was installed from RhoMobile Suite 2.21.12)

                       

                      - Eclipse 4.2 Juno with DLTK 4.0

                       

                      All of these do the same thing. I get the error on line one of every ERB file if the project was recently-generated with Rhodes. I don't get the error on my pre-existing projects.

                       

                      It's possibly some setting that I turned off on my old projects to avoid seeing this error, but I think it odd that this seems to be the case for ALL of my old projects.

                       

                      If I manually create an ERB (file, new) I still get this error as well.

                       

                      If I manually create an ERB in an old project, but with the same version of Eclipse, I do not get the error.

                       

                      So, it has to be some project setting I think. My old projects may all have one setting, while newly-created projects have a different setting. I just don't know what that setting is!