3 Replies Latest reply on Jan 10, 2013 8:11 AM by Florin Cretu

    Program Memory Low

    Florin Cretu

      Hello,

      I use RhoElements 2.2.1.12 on MC9190-G Win CE - OM Version: 2.32.0004.

      Once or tow time a day i need to cold boot the terminal for this error:

      -Title window: Program Memory Low

      -Text on window: Select one task to close or increase program memory.

      -Option Box: Storage to program memory.

       

      Can not access device with USB cable.

      Can not restart device with power button.

      I only can make a cold boot.

       

      I have my log on RhoElements Home = \Programe Files, I will change to be in \Applications so remain on cold boot.

      I attach 1 hour before error log.

        • Re: Program Memory Low
          Glenn Sayer

          I have seen this when a single page application is being used and a refresh is not done for a long time. A refresh will cause memory to be cleaned up.

          • Re: Program Memory Low
            Florin Cretu

            I add log @ error time on 2 device.

             

            ----

            I add a 3'rt log with hi memory usage:

             

             

            I 01/10/2013 09:10:52:000 08390002               MEMORY| Stats: Load=29%  TotalPhy=129136KB  FreePhy=92616KB  TotalVM=1048576KB  FreeVM=1021696KB

            I 01/10/2013 09:10:55:000 082c0002     Core::CSync::Run| Running Event:

            I 01/10/2013 09:10:55:000 082c0002     Core::CSync::Run| Posting Message for:

            I 01/10/2013 09:10:56:000 082c0002              WebView| Page load complete.

            I 01/10/2013 09:10:56:000 082c0002     Core::CSync::Run| Running Event:

            I 01/10/2013 09:10:56:000 082c0002     Core::CSync::Run| Posting Message for:

            I 01/10/2013 09:10:56:000 082c0002     Core::CSync::Run| Running Event:

            I 01/10/2013 09:10:56:000 082c0002     Core::CSync::Run| Posting Message for:

            I 01/10/2013 09:10:56:000 082c0002 Core::CMeta::GetModule| Plug-in: contentcannot be found in Plugin.xml

            W 01/10/2013 09:10:56:000 082c0002 Core::CMeta::SetPlugProperty| Module content not found.

            I 01/10/2013 09:10:56:000 082c0002 Core::CMeta::GetModule| Plug-in: contentcannot be found in Plugin.xml

            W 01/10/2013 09:10:56:000 082c0002 Core::CMeta::SetPlugProperty| Module content not found.

            I 01/10/2013 09:10:56:000 09370006 Scanner::CScanner::EnableDecoder| Attempted to enable the decoder code93 but it is already enabled

            W 01/10/2013 09:10:56:000 09370006 Scanner::CScanner::Set_code93_MetaProc| Unable to set Parameter code93 to Value enabled

            I 01/10/2013 09:11:02:000 082c0002     Core::CSync::Run| Running Event:

            I 01/10/2013 09:11:02:000 082c0002     Core::CSync::Run| Posting Message for:

            I 01/10/2013 09:11:03:000 082c0002              WebView| Page load complete.

            I 01/10/2013 09:11:03:000 082c0002     Core::CSync::Run| Running Event:

            I 01/10/2013 09:11:03:000 082c0002     Core::CSync::Run| Posting Message for:

            I 01/10/2013 09:11:20:000 082c0002     Core::CSync::Run| Running Event:

            I 01/10/2013 09:11:20:000 082c0002     Core::CSync::Run| Posting Message for:

            I 01/10/2013 09:11:20:000 082c0002 Core::CMeta::GetModule| Plug-in: contentcannot be found in Plugin.xml

            W 01/10/2013 09:11:20:000 082c0002 Core::CMeta::SetPlugProperty| Module content not found.

            I 01/10/2013 09:11:20:000 082c0002 Core::CMeta::GetModule| Plug-in: contentcannot be found in Plugin.xml

            W 01/10/2013 09:11:20:000 082c0002 Core::CMeta::SetPlugProperty| Module content not found.

            I 01/10/2013 09:11:20:000 08390002               MEMORY| Stats: Load=69%  TotalPhy=129136KB  FreePhy=40080KB  TotalVM=1048576KB  FreeVM=980416KB

             

            Please help me read this section of code.