MSP Client Software on Intermec CN50

Hi,
I have to demonstrate CN50 (WM6.1) management with MSP4 and I am not able to make it works as expected.
The MSP Generic Client (MspAgent_dwd_7.07.28.cab) has been installed and both RD client and MSP Agent are into the device. The RD client can start the scanner but after reading the profile the status always display waiting...(even if we add an Enter key in the wedge scanning software) and never process the Staging.
The only way to start a Staging is to do an electronic staging in ActiveSync mode but once again there is a message error during the process (error -839). The staging goal is to start the Agent on the device  so we tested enable30, Debug30 and also our own Agent.setting with the same issue. In fact the CN50 does not appear in the Staging devices but is available in the Device status and reported some informations like OS Version, MSP Agent version, etc...but the Agent is not started.
If we put the Relay Server informations manually in the AirBeam agent, start the MSP Agent Manually and force check in,  we can see the connexion on the FTP server. Trying to make an action the CN50 never download the package even if the job is available for it.
Does anybody have any experience that could help troubleshooting ?

Thanks
Rudra Thakur
Hello Eric, For

Hello Eric,

For troubleshooting, please see if you have the following:

1. Relay server is selected in the staging profile that you have created.

2. In the Bundle along with the enable30 package add a step to warm boot the device. You could use the 'Warm Boot with reg merge' option. This would start the agent on warm boot of the device.

Regards,
Rudra
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Allan Herrod
Erick; I would not expect


Erick;

I would not expect Barcode-based Staging to work since that is not part of the Core functionality that is defined as what is supported by the Generic Client.  You can find the list of Core functionality should be supported in the Release Notes.   As for On-Demand, I would expect that to work. Error -839 seems like an issue with the Relay Server.  Have you tried Staging any other device with the same Staging Profile via ActiveSync via that same PC?  Does it work or get the same error?

In general, during installation of the MSP Agent, a reboot is generally required to complete the installation so the agent will start properly.  If this didn't happen, then perhaps the agent is not properly installed which could be leading to all the other problems you are seeing.  Did you install the CAB manually or as part of Web-Based Self-Enrollment?

We have used the Generic Client on a variety of Windows Mobile devices with no issue, so I am surprised you are having issues.  We need to get to the bottom of this.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Erick Rondin
Allan, The same architecture

Allan,
The same architecture is working perfectly with a Motorola device, I was able to stage debug30 with no issue using ActiveSync On Demand. I also clean boot the CN50 and re install the cab file using ActiveSync connexion, the installation asked to reboot. After reboot, the On demand staging process using ActiveSync or WLAN start as usual (Registering Device, Loading Bundle), I can see the CN50 UUID appears on the ON Demand screen but during the process I can on the CN50, the message reconnecting and Loading Bundle switching and after several attempts, the message Uploading Stage Log is displayed following by disconnecting and finally Error -839 API error.
In the RD view log file I can see a 801 error message file creation error . As I already wrote, the CN50 is displayed in the MSP Device Status even if the Staging has not been done correctly.
I can provide you more details from the FTP log or whatever you will need to help troubleshoot that issue.
Thanks
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Allan Herrod
Erick; I cannot work on


Erick;

I cannot work on troubleshooting this issue.  But if you open a case with the help desk, they can assist you or get someone from MSP engineering assigned if/when they cannot solve your problem themselves.

Allan
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Erick Rondin
Allan, I can understand you

Allan,
I can understand you are not the right people to work on that but to let you know, here is the answer from the support : '

Hi Erick,

 

I am not sure which version of the Client Software Guide you have, in the MSP Client Software Guide – MSP 4, you can find the information below. Regarding this information not every unit, which is running Windows Mobile is supported. The list of supported (tested) products can be found in Release Notes to MSP 4. From Intermec there are mentioned the unit CN3 and CV3070 and not the CN50. For supporting this device directly you will need to open a GRIP. '

Open a grip is not the solution to move forward quickly on the issue and technical support does not support the CN50...
What do you sugggest, saying to the customer we can't manage the CN50 ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Larry Dykes
Hi Eric, Since the manual

Hi Eric,

Since the manual says 839 occurs when "a file could not be opened on the Relay Sever" I would think your best next-step is to get the details of the interaction between the cn50 and the RS.
Can you get a trace of the conversation from the server? If not, can you get a packet capture trace for wireshark?

Larry
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Larry Dykes
Erick, One more quick-and

Erick,

One more quick-and-dirty diagnostic idea: if it's hard to get a trace from the server, there may be a simpler way to find what's going wrong.

Since you mention that this version of the client has an AirBEAM interface -- if you configure the AirBEAM package list with the full name of the package you want to pull down, and tell it to synch manually and watch the screen, AirBEAM should show you a progress report file by file. So if there is a problem opening a file, as the 839 says, then you should be able to determine which file is the problem without doing a trace.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Erick Rondin
Hi Larry, The traces has been

Hi Larry,
The traces has been providede to the technical support for help. I also tried you very good idea with the AirBeam client and I have the error message Missing package temp directory. I had a look into the AirBeam status mesages and this error message indicates that the AirBEAM package directory is missing. This directory is created automatically during the Client initialization.

 

 

 

Do you have an idea on what could be wrong ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Milan Riha
Hi Larry, I have attached

Hi Larry,

I have attached FTP logs and traces which I have got from Erick.

In the screen shots you can see also error as the first one  -801 Fatal error during creation of file on mobile computer.

Erick,

I had similar case with MC17s. The reason for this error was that Airbeam folder was blank (no subfolders).

Milan
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Larry Dykes
0.47 never appears on network

0.47 never appears on network trace, never logs into FTP server

0.45 logs in and puts 001346996ab5010803535695e69a7aca_discovery_0ecf.xml in the DISCOVERY folder,

something only the CN50 should do. So the CN50 must be using the network through the PC and not the wireless.

putting this file in DISCOVERY should be normal in staging - it reports the results of the staging operation - and we do not see a request to list JOBS.

note the attributes in the screen shots show no package inventory, consistent with nothing being successfully downloaded.  

but I don't know if it is normal to send this in BEFORE downloading the staging bundle.

right after uploading its attributes to DISCOVERY,  0.45 logs in, sets TYPE I, waits 5 seconds and disconnects without even setting PASV, then immediately repeats this action.

it does this 7 times in the log segment shown.

But the trace shows no download request from 0.47 or 0.45

the CN50 never requests a bundle or any file from the relay server.
You can see the "error trying to create file" in the agent log.

Could it be the CN50 is attempting to download a file to a folder that does not exist?
This might give error trying to create file - would that occur before a download request was made to the FTP server?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Erick Rondin
Larry, As a conclusion, I

Larry,
As a conclusion, I made a test on a CN50 running the English OS version and everything seems to work as expected. The problem is always visible on the French OS, that never installed the good AirBeam folders during cab installation.
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Log in to post comments