3 Replies Latest reply on Jan 28, 2013 4:57 AM by Daniel Freeman

    Where is RhoConnect?

      I want to set a path to rhoconnect.  But I can't figure out where the installer has put it.

       

      Originally, I thought my problem was due to redis missing.  So I installed it from scratch from their website, and appended a path to it.

       

      Now, if I try to run a rhoconnect application I get a warning in the eclipse console window:

       

       

      WARNING: dtach not installed or not on path, some tasks will not work!

        Install with '[sudo] rhoconnect dtach-install'

       

      And I get a message in a Terminal window:

       

      -bash: rhoconnect: command not found

       

      I'm using MacOS X 10.6.

        • Re: Where is RhoConnect?

          When you install RhoMobileSuite the "Install gems" script on the disk image will install rhoconnect for you.  As long as you have your rvm environment setup as described then your rubygem bin directory will be on your path and the rhoconnect command will be found.

            • Re: Where is RhoConnect?

              I tried reinstalling again.  I've just gone through it again, and the outcome is the same.  echo $PATH is unaffected too.

               

              Here's what I did:-

               

              1. throw Applications/RhoStudio folder in the trash.

              2. Open RMS_02010107.dmg
              3. install gems

               

              The next two steps, I hadn't done previously (but they didn't help).

               

              4. Install node-v0.8.4.pkg

              5. Install rhoconnect-push

               

              6. drag and drop Motorola RhoStudio folder into applications.

              7. run RhoStudio.  Create a new rhoConnect project (because this seems to force further installations - the first time you do it)

              8. type password into Terminal window when prompted.
              9. try to run a rhoconnect application.  Fails with diagnostics described above.

               

              Note that echo $PATH has not been affected by the installation.  I tried restarting also.

               

              I've heard that appending new paths to PATH is different for Lion and Mountain Lion.  I'm using Snow Leopard - is there a problem with that?  Do your installers still work for 10.6.8?  Also, I previously edited my .bash_profile file - does that interfere somehow?