2 Replies Latest reply on Nov 7, 2014 10:47 AM by Robert Galvin

    RhoMobile.com and Git

    Jeffrey Cookle

      Just wondering if anyone else is having issues with RhoMobile.com and using Git to push changes to their projects?   About 90% of the time I am getting an error that my project is "not a valid a Git Repository" or the connection times out, even after setting the timeout to 180 in RhoStudio.  It seems to be happening more after the major changes that happened end of August timeframe and after we upgraded to RhoStudio 5.0.

       

      Two days ago I could push changes several times in the morning and got errors the rest of the day, no matter what the project was.  Here is what I have tried so far from my Windows 7 laptop:

       

      • Opened a support ticket, still waiting for a response
      • Reverted back for a bit to RhoStudio 4 and still got errors
      • Updated the SSH Keys and put them on RhoMobile.com for my account
      • Tried using a different tool outside of RhoStudio 5.0, like SourceTree
      • Disabled firewall on my computer and tried from both inside our work network and from home.
      • Tried different versions of Git

       

      We use GitHub in our organization a lot of don't have issues like this, but when I try to reach git.rhohub.com it fails a lot for pushes and fetches.

       

      Any suggestions would be greatly appreciated as this is slowing down our ability to make changes to our applications and build for iOS on RhoMobile.com.

       

      Thank you!

        • Re: RhoMobile.com and Git
          Kutir Mobility

          Hi Jeffrey,

          It seems you have tried all options. This issue needs assistance from Motorola folks. Lets wait to hear from them.

           

          Thank you

          Kutir Mobility

          • Re: RhoMobile.com and Git
            Robert Galvin

            Hi Jeff,

             

            The good news is that we are aware of the issue and we are in the process of implementing an alternative for our git servers using Github. This would allow our build servers to clone a user’s github repo, and then build their source (thus by-passing our git servers). We are in the middle of developing this for our ‘test’ instance. We hope to have this up soon (at least in test), but I can not give an ETA.

             

            The bad news is that you basically just have to keep trying.

             

            Rob