2 Replies Latest reply on Dec 11, 2014 7:56 AM by Andrew Wood

    It looks like that Microsoft may have removed the capability of passing credentials in the URL.

    Andrew Wood

      One of our customers has a web application that requires authentication.


      On the MC9090 HHTs, our launcher simply sets the URL to: http://domain%5cusername:password@ssm.webapps.joebloggs.com/cssm_hhtuiabstractA/menu.aspx.

       

      – where domain, username and password are replaced with the particular user’s actual details. 


      Internet Explorer on the 9090 authenticates (using NTLM to pass the credentials to the server) and it works.

       

      However, on the MC92N0, the browser displays a popup message: This URL is not correctly formatted. Please verify you have entered the correct address

       

      I’m seeing various posts on the Internet on how to re-enable this feature – eg. At  http://support.microsoft.com/kb/834489.  I’ve set the recommended registry entries in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER.  But nothing I do makes any difference.  It’s possible that there’s a different workaround for the Mobile Internet Explorer – but I can’t find it.  


      Any help will be appreciated!