8 Replies Latest reply on Apr 2, 2013 6:47 AM by John Michael Vincent Rustia

    Uploading file in HTTPS connections failing

      We have a native application that is tested on android devices. If we test it against our test server that uses http connections, uploading of files doesn't have any issues, works like a charm. Unlike when we connect to a server with https connection it always failed. It doesn't fail on rhosimulator whether https or not But on real devices,when it comes on https connection it always failed no matter what android version we try(gingerbread and ICS).

      We are suspecting this has something to do with rhomobile internal implementation on handling https connection when uploading file and we found other forum post that could be related to this issue,

      https://developer.motorolasolutions.com/message/3049#3049

       

      The work around that we tried is to customize the config.xml, and use a fix suggested by motorola support

       

       <VerifyPeerCertificates value=”false” />


      It  works now on android emulator both on ICS and Gingerbread using the fix(before it was not working also on android emulators).

      But on real android devices, still the issue persist and we couldn't upload files on https connection.

       

      We are using LG gingerbread device and Samsung Galaxy Note 2(ICS) for testing.

        • Re: Uploading file in HTTPS connections failing
          Robert Galvin

          Is this app using apptype='RhoElements' which would use Motorola Webkit or is it using the native webkit?

           

          What happens when you just try connect with the real device's browser? is the server in a public accessible location for me to try?

           

          Moto Webkit only supports a limited number of Cypher strengths and if your server does not allow these then it will not work:

          • TLS_DHE_RSA_WITH_AES_256_CBC_SHA (0x0039)
          • TLS_DHE_DSS_WITH_AES_256_CBC_SHA (0x0038)
          • TLS_RSA_WITH_AES_256_CBC_SHA (0x0035)
          • TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA (0x0016)
          • TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA (0x0013)
          • TLS_RSA_WITH_3DES_EDE_CBC_SHA (0x000a)
          • TLS_DHE_RSA_WITH_AES_128_CBC_SHA (0x0033)
          • TLS_DHE_DSS_WITH_AES_128_CBC_SHA (0x0032)
          • TLS_RSA_WITH_AES_128_CBC_SHA (0x002f)
          • TLS_RSA_WITH_RC4_128_SHA (0x0005)
          • TLS_RSA_WITH_RC4_128_MD5 (0x0004)
          • TLS_DHE_RSA_WITH_DES_CBC_SHA (0x0015)
          • TLS_DHE_DSS_WITH_DES_CBC_SHA (0x0012)
          • TLS_RSA_WITH_DES_CBC_SHA (0x0009)
          • TLS_DHE_RSA_EXPORT_WITH_DES40_CBC_SHA (0x0014)
          • TLS_DHE_DSS_EXPORT_WITH_DES40_CBC_SHA (0x0011)
          • TLS_RSA_EXPORT_WITH_DES40_CBC_SHA (0x0008)
          • TLS_RSA_EXPORT_WITH_RC2_CBC_40_MD5 (0x0006)
          • TLS_RSA_EXPORT_WITH_RC4_40_MD5 (0x0003)
          • TLS_EMPTY_RENEGOTIATION_INFO_SCSV (0x00ff)