6 Replies Latest reply on Apr 13, 2013 11:56 PM by Moazzam Ali Khan

    Error in starting RhoConnect Adapter

      I am newbie to RhoConnect Studio. I am trying to create a demo application in RhoConnect. When i try to create RhoConnect Source Adapter, it throws error:

      Could not find gem 'SystemTimer (~> 1.2.3) ruby' 

      I am using Ruby 1.9.3 and RhoConnect 3.3.4 I googled and found that for Ruby 1.9.x, SystemTimer is not used. I also checked my current Ruby version using rvm even though same error comes again and again.

      Please help

      Thanks in advance

        • Re: Error in starting RhoConnect Adapter

          On which platform are u? Mac OSX or Windows? It looks like RhoStudio uses system ruby that obsolete. Start RhoStudio form console, it will ask you with ruby to use, select 1.9.3 then.

            • Re: Error in starting RhoConnect Adapter

              Its Mac OSX. I know this and i am opening it from the terminal only and RhoElements are working fine. I have made this demo http://docs.rhomobile.com/rhoelements/rhoelements-tutorial and its working but on creating RhoConnect Source Adapter in RHoConnect application, its giving this error.

                • Re: Error in starting RhoConnect Adapter

                  Can you do the following commands in console from your project directory and post results, pls:

                   

                  $ ruby -v

                  $ rhoconnect  source <your-adapter-name>

                    • Re: Error in starting RhoConnect Adapter

                      Thanks for the reply.

                      For $ ruby -v :-

                      ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin10.8.0]

                       

                      and for $ rhoconnect  source adapter1 :-

                      /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/resolver.rb:287:in `resolve': Could not find gem 'SystemTimer (~> 1.2.3) ruby' in the gems available on this machine. (Bundler::GemNotFound)

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/resolver.rb:161:in `start'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/resolver.rb:128:in `block in resolve'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/resolver.rb:127:in `catch'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/resolver.rb:127:in `resolve'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/definition.rb:192:in `resolve'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/definition.rb:127:in `specs'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.5/lib/bundler/environment.rb:27:in `specs'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1.0.6/lib/rubygems-bundler/noexec.rb:41:in `candidate?'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1.0.6/lib/rubygems-bundler/noexec.rb:60:in `setup'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1.0.6/lib/rubygems-bundler/noexec.rb:75:in `<top (required)>'

                                from /Users/training/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `require'

                                from /Users/training/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'

                                from /Users/training/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require'

                                from /Users/training/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:9:in `<main>'