rvm install issue


How do I install rvm in my iMac v10.7.5?

Saurabh Khemka
I am now able to install rvm

I am now able to install rvm in my machine. But When I click on "install gems" file in RhoStudio package for MAC, I get the following error message the screenshot of which is attached. When I enter Y and press enter, I get the message that could not locate repository. Please help.

Screen Shot 2013-04-15 at 1.27.13 AM.png

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Peter Arcuri
Based on your snapshot, your

Based on your snapshot, your "system" ruby version is 1.8.7. RhoStudio needs ruby 1.9.3. If you have installed ruby 1.9.3, then you'll have to make it default to the system. See list of commands below and compare with what you have done and fill in the blanks.

Command to install Ruby 1.9.3 => user$ sudo rvm install 1.9.3

Command to use newly installed Ruby => user$ rvm use 1.9.3

Command to check if it worked => user$ ruby -v

Command to us as default for new shells (will override the "system" ruby) => user$ rvm use 1.9.3 --default

Hope this helps.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kutir Mobility
Hi Saurabh In order to

Hi Saurabh

In order to install Rhodes gem, you need ruby 1.9.3 or greater. This link http://www.ruby-lang.org/en/downloads/ will help you to install ruby.

Hope installing ruby latest version will resolve your issue.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Saurabh Khemka
I executed the command "rvm

I executed the command "rvm install 1.9.3" in the terminal and is getting the following. Please help.

Screen Shot 2013-04-19 at 12.17.13 AM.pngScreen Shot 2013-04-19 at 12.17.19 AM.png

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kutir Mobility
Hi Saurabh Khemka,Please try

Hi Saurabh Khemka,

Please try this

run "rvm update head" , then "rvm requirements" then install the packages recommenmed by it and finally run "rvm install 1.9.3".


Thanks

Surendran S

Kutir Mobility

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Saurabh Khemka
$ rvm update head gives

$ rvm update head gives Unrecognised command line argument "head".

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Saurabh Khemka
I installed rvm and on typing

I installed rvm and on typing " typr rvm | head -n 1 " gives rvm is a function. Now I want to update ruby version from 1.8.7 to 1.9.3. Please suggest.Screen Shot 2013-04-19 at 1.47.38 AM.png

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kutir Mobility
Hi Saurabh Mac is trying to

Hi Saurabh

Mac is trying to install the necessary things as mentioned in rvm requirements before installing ruby 1.9.3. Seems like you haven't configured the git in your Mac. Make sure you configure git user details to resolve this issue.

Hope it helps

Thanks

Dhepthi

Kuitr mobility

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Saurabh Khemka
I installed ruby 1.9.3. When

I installed ruby 1.9.3. When I am clicking on "install gems" file in the dmg package, the following screen is displayed. Please suggest.

Screen Shot 2013-04-22 at 4.07.33 AM.png

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kutir Mobility
Since it is a problem with

Since it is a problem with you local machine, our suggestion is to go with Rhomobile suite installer which has  all the steps for you.

Thanks

Surendran S

Kutir Mobility

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


DecisionPoint K...
You don't want to install the

You don't want to install the gems with sudo, nor do you want to install RVM with sudo. But RVM may require sudo for some installation steps. Installing RVM or RhoMobile with sudo will likely break MacRuby, and complicate things much more than you're going to want. If you type rvm use, you should see something like "Using /Users/you/.rvm/gems/ruby-1.9.3-...". If not, try "rvm use 1.9.3" and see what it tells you.

If you want to start over from scratch with RVM, then use "rvm implode". Don't use "rvm get head", as that installs the latest development version of RVM. You instead want "rvm get stable", unless you know you need RVM head.

So, to do all of this the best way possible, once RVM has been completely uninstalled (I also assume that you already have Xcode and the Command Line Tools installed, if not, do that now):

  1. Install RVM as your user - not sudo. Follow the directions on rvm.io.
  2. Install Homebrew if you have not already (http://mxcl.github.io/homebrew/). If you have, brew update.
  3. Turn on RVM autolibs (rvm autolibs enable).
  4. Install Ruby 1.9.3 (rvm install 1.9.3). It will use Homebrew to install certain dependencies as needed.
  5. Open the RhoElements DMG and run "Install gems". Pick the correct Ruby (1.9.3) and do not install with sudo.
  6. Wait while it installs RhoElements.
  7. It should complete successfully.

Hope that gets you on the right track!

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Kutir Mobility
Hi SaurabhCan you try

Hi Saurabh

Can you try checking the sources added in your system? Try to add below sources to your system

gem sources --add http://rubygems.org

After adding the source, try installing gems

Hope it hepls

Thanks

Dhepthi

Kutir Mobility

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Saurabh Khemka
I have ruby 1.9.3 installed

I have ruby 1.9.3 installed in my iMac.

ruby -v gives ruby 1.9.3p392 (2013-02-22 revision 39386) [x86_64-darwin11.4.2]

I installed rvm and homebrew also.

type rvm | head -n 1 gives rvm is a function.

I downloaded RhoStudio dmg file and extracted that on the desktop. Clicking "install gems" gives the following error. I tried installing without sudo also but no success. Please suggest.

image_png.png

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Saurabh Khemka
Hi,On click install gems file

Hi,

On click install gems file in the dmg, it asked for Ruby version and I selected 1.9.3. Then it asked if you want to install with sudo or not and I selected N.

On pressing enter, it is throwing Gem: FilePermissionError /users/saurabh_khemka/.rvm/gems/........ Please suggest.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


DecisionPoint K...
Your RVM installation seems

Your RVM installation seems to be messed up. It appears that the root user, via sudo, installed some components of RhoElements and RVM, which is causing things to break down. Since root owns the data, rather than your user, RVM is unable to function as it lacks the proper permissions. You could play with permissions and make it probably work, but I wouldn't recommend doing this as it may cause problems down the road that you probably don't want to deal with. The simplest solution is to use rvm implode to uninstall RVM, then reinstall. You can read more about that here, or you can just copy-paste this into a terminal and press enter:

\curl -#L https://get.rvm.io | bash -s stable --autolibs=3 --ruby

(Yes, there is a backslash at the beginning of the line.)

When you install RhoElements, be sure to answer "no" to the sudo question. Everything should work after that.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments