7 Replies Latest reply on May 7, 2013 4:15 AM by Stephen McIntosh

    Building with iOS 6 on RhoHub

      Hi, I'm trying to build my app against iOS 6 on RhoHub. I've specified the following in my build.yml:

       

      iphone:

        sdk: iphoneos6.1

       

      (I've also tried 6.0)

      However, the build log still shows the following:

       

      iphoneos5.0

      Check SDK :

      PWD: /opt/resque/sdk/rhodes-3.5.1.12

      CMD: /Developer/usr/bin/xcodebuild -version -sdk iphoneos5.0

      RET: iPhoneOS5.0.sdk - iOS 5.0 (iphoneos5.0)

      RET: SDKVersion: 5.0

      RET: Path: /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.0.sdk

      RET: PlatformVersion: 5.0

      RET: PlatformPath: /Developer/Platforms/iPhoneOS.platform

      RET: ProductBuildVersion: 9A334

      RET: ProductCopyright: 1983-2011 Apple Inc.

      RET: ProductName: iPhone OS

      RET: ProductVersion: 5.0

      RET:

      cd /opt/resque/sdk/rhodes-3.5.1.12

      rm -rf /opt/resque/build/describability/Describability-rhodes/bin/target/iOS

      cd platform/iphone

      iPhoneOS5.0.sdk - iOS 5.0 (iphoneos5.0)

      SDKVersion: 5.0

      Path: /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.0.sdk

      PlatformVersion: 5.0

      PlatformPath: /Developer/Platforms/iPhoneOS.platform

       

       

       

      So it is being built against iOS 5.0 despite what I'm specifying. Am I configuring this correctly? How do I build against 6.0 or higher on RhoHub?

       

      When I submit my app to Apple I get a warning saying that they will stop accepting apps built against anything lower than iOS 6.0 on the 1st of May so I've only got a week to work this out.

      Any help would be much appreciated!

       

      Thanks,

      Stephen