1 Reply Latest reply on May 5, 2016 7:46 PM by Charitha Mallawaarachchi

    Lots of Gradle error on Android Studio 2.1, EMDK 4.0

    Wookjin Jung

      I am beginner of EMDK device.

      After I install EMDK  4.0 and create new project with Compiled sdk 19 with EMDK 4.0

       

      compileSdkVersion '"Symbol Technologies LLC":EMDK 4.0 (API 19):19'

       

      I see a lot of errors like this

       

       

      Any ideas?

       

      I have windows 10, Android Studio 2.1, EMDK 4.0

       

      Thanks,

      WJ

        • Re: Lots of Gradle error on Android Studio 2.1, EMDK 4.0
          Charitha Mallawaarachchi

          Hi Wookjin,

           

          few things:

           

          EMDK does not support Windows 10 officially in 4.0. Readme says:

          Microsoft® Windows 7 (32-bit and 64-bit)  or Microsoft® Windows 8 (32-bit and 64-bit) or Microsoft® Windows 8.1 (32-bit and 64-bit).

           

          Please try to open a sample project provided with EMDK to see if it is working fine. You may download the source for Android Studio.

          Barcode APIs - Zebra Technologies Online Documentation

           

          If it is working, then you can start your project step by step.

          1. Create a blank project and compile. Make sure to have Android 4.4 (API 19) is selected.

          2. Make the UI without configuring EMDK API versions.

          3. Add EMDK without programming EMDK. (EMDK 4.0 (API 19)

          4. Add EMDK API calls.

           

          This will help you identify where you have the issue. Post back if you need further help.

           

          Thanks,

          Charith.