[MC40 Android] FATAL EXCEPTION: ScannerHandlerThread

Hello guys,

 

I'm having a problem with EMDK implemented in MC40 device (precise number: N0-SLK3R01).

 

 

It happens randomly and unexpectedly.

 

Here comes the log from stack:

 

 

FATAL EXCEPTION: ScannerHandlerThread

                                                  Process: com.symbol.emdk.emdkservice, PID: 2351

                                                  java.lang.RuntimeException: startPreview failed

                                                      at com.symbol.scanning.imager.Imager.startPreview(Native Method)

                                                      at com.symbol.scanning.imager.ImagerScanner.enable(ImagerScanner.java:305)

                                                      at com.symbol.emdk.emdkservice.barcode.SvcScanner$2.run(SvcScanner.java:351)

                                                      at android.os.Handler.handleCallback(Handler.java:733)

                                                      at android.os.Handler.dispatchMessage(Handler.java:95)

                                                      at android.os.Looper.loop(Looper.java:136)

                                                      at android.os.HandlerThread.run(HandlerThread.java:61)

 

 

Could you provide any suggestion of what could be the reason of such occurrence?

 

Please let me know if any additional information is helpful for you to find it out.


Some details that comes to my mind as useful:
- I'm using Wrapper class

 

Best regards,

Jacek

Pietro Francesc...
Hi Jacek,fre questions:-

Hi Jacek,

fre questions:

- which BSP version are you using on your MC40 (it's the build number in the Settings->about device panel)?

- Which EMDK version are you using and have you installed the same EMDK runtime on the device?

~Pietro

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jacek Rys
Hello Pietro,thank you for

Hello Pietro,

thank you for your reaction.

These are my answers:
- Build number: 01-12-03-4AJ22-K-V0-M1-072015
- I'm using .jar lib from emdk_v4.0_API-19. I didn't install any EMDK runtime on the device.

Hope it helps.

~Jacek

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
You will need to install the

You will need to install the EMDK runtime on the device.  The version that comes with that OS release is older than the current EMDK.

See the getting started doc, specifically "Configuring a Device".

Getting Started - Zebra Technologies Techdocs

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jacek Rys
Hello Dan,thank you. I

Hello Dan,

thank you. I upgraded the device as you recommended. I will let you know if the issue occurs again. For now we can close the this thread. I will reopen that topic with new info later on, if needed.

~Jacek

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments