5 Replies Latest reply on Jun 25, 2013 8:23 AM by Lars Burgess

    ERR In Connecting Oracle DB

      Hi All,

       

      I am getting error in connecting oracle DB with Oci8 gem.

       

      I have written any code in my source adapter:

       

      require 'json'

      require 'oci8'

       

      class Employee < SourceAdapter

        def initialize(source)

          @conn = OCI8.new('hr','123456','//127.0.0.1:1521/xe')

          super(source)

        end

       

      C:/MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/gems/1.9.1/gems/ruby-oci8-2.1.5-x

      86-mingw32/lib/oci8.rb:81:in `initialize': wrong number of arguments (2 for 0..1

      ) (ArgumentError)

              from C:/MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/gems/1.9.1/gems/ruby

      -oci8-2.1.5-x86-mingw32/lib/oci8.rb:81:in `new'

              from C:/MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/gems/1.9.1/gems/ruby

      -oci8-2.1.5-x86-mingw32/lib/oci8.rb:81:in `require'

              from C:/MotorolaRhoMobileSuite2.1.1.7/ruby/lib/ruby/gems/1.9.1/gems/ruby

      -oci8-2.1.5-x86-mingw32/lib/oci8.rb:81:in `<top (required)>'

          

       

      Please help me out.

       

      Thanks in advance!!