macOS Installer terminating immediately

Hi,

I just tried starting the mpsdk-installer-2-13 on my brand-new mac (macOS 10.13.3). It opens and then closes immediately.
After inspecting the installer package, and I saw a lot of Java classes in it, could it be, that java is required for installing the SDK?

I also found during inspection the SDK for iOS in a zip file, which is why I was going to install the SDK in the first place. Is there any disadvantage to just using this directly without getting the installer to work?

Best regards,

Hannes