3 Replies Latest reply on Jul 12, 2013 9:01 AM by Nicolas Grolleau

    How to install/deploy Licenses

    Guillermo James

      Hello.

       

      Actually we already have an application licenses for our RhoElement application version 2.2, however when we follow the directions from this document (http://docs.rhomobile.com/rhoelements/licensing), we are unable to avoid the DEMO screen from RhoElement. We notice that there are 2 ways to include the license key into our code, one of them is from the build.yml or config.xml. Our application we think it is a native one, since we started developing always in RhoStudio, thus we think that the build.yml should be the way, but we are failing. We never tried the config.xml way.

       

      Any help would be highly appreciated.

      Thanks!

        • Re: How to install/deploy Licenses
          Travis Chun

          Having the same issue as Guillermo James tried licensing for both Moto and Non-Moto devices running win mobile 6.5.  I emailed multiple people on the Moto Rho team and never got an answer.  Very frustrating.

          • Re: How to install/deploy Licenses
            Gerbrand Stap

            We have an application license applied to our app, and it works just fine.

            In the build.yml we specified (including the quotes):

             

            motorola_license: "our 136 character license key"

             

            As the documentation states, you should NOT include the motorola_license_company setting.

            But what do you mean by the DEMO screen? When you need a license, but do not have any valid one, you will get the message: "Please provide RhoElements license key.". Do you mean that message?

             

            If you are wondering whether you are using the right file to specify the license, you should look at: http://docs.rhomobile.com/rhoelements/rhoelements-app-models

            'Native' is RhoElements v2, so applications developed in RhoMobile Suite/RhoStudio

            'Hybrid' is RhoElements v1/Pocketbrowser, so the 'old-fashioned' method.

            • Re: How to install/deploy Licenses
              Nicolas Grolleau

              You have to make sure the "name" parameter in build.yml is the same as the application name given when you purchased the license.

              To know if the license is seen by the framework, you can look in the log file, you will see either "Application license not present in configuration file" (means that maybe you did not put the motorola_license line at the good place in the file) or "Application license found in configuration but could not be applied" (means the line is found but for some reason it's not working)

               

              In my case the problem was a bad license provided by motorola.

              If you have the good application name in build.yml and it doesn't work, maybe it's because you have the same issue.

              (it's not because your license is not 136 characters that it's bad : my new license that works is only 98 chars long).