0 Replies Latest reply on Sep 10, 2013 12:26 PM by Jack Burleson

    Stopping Accidental Bar Code Imager Firing when using VoIP App on MC40 - Here's a Method

    Jack Burleson

      One issue I have experienced is accidentally pressing the "bar code scanning" buttons on the side of the MC40 while in a VoIP conversation with the device.  One method I have identified to "fix" this issue is to disable the  Bar Code Imager while the VoIP client has focus.  Here is the method to do this:

      - Got to Apps > Datawedge > Menu > New Profile.

      - Create a profile name - for example Jabber-noScan

      - In the profile go to "Applications - Associated Applications" and perform menu > New app/activity

      - Scroll down thru the apps listed and select the VoIP app (or other app) in which you wish to DISABLE bar code scanning accidental turn on and scanning.  In this example, I select com.cisco.jabber

      - A list of activities will be displayed for the app.  Press the * (asterisk) at the top of the screen to select ALL.

      - Press the back arrow button.

      - Scroll down to "Barcode Input" and UNCHECK the "Enabled" box.  If you have a MSR MC40 also go and uncheck the Enabled for MSR input.

      - Click the back arrows until you exit Datawedge.

      - The bar code buttons now are disabled when Jabber has focus on the display.

       

      Attached is a sample Jellybean OS Datawedge profile with the above actions completed.  You can import it into your JB datawedge setup as follows:

      - Copy file to the MC40 SDCard

      - Go to apps > datawedge > menu > settings > Import Profile

      - A list of the profiles that you have on the device SD card will be listed.  Ensure the blue radio button beside dwprofile_Jabber-noScan is highlighted and press Import

      - Exit datawedge and the scanner should not illuminate when Jabber has focus on your MC40.

       

      Good Luck!