6 Replies Latest reply on Sep 20, 2013 4:01 AM by Kutir Mobility

    Is RhoConnect 4.0.0 beta or release?

    Andrew Webster

      Hello,

       

      I've just installed a new server on CentOS using instructions provided at: http://docs.rhomobile.com/rhoconnect/deploying,and ended up with rhoConnect 4.0.0.  Is this a GA release or beta?

      The problem is my application is written for rhoConnect 3.4.4, and the thin server will not start due to an apparent rake version mismatch.

      I've noticed that rhoconnect 3.4.4 is installed as well, however thin does not appear to run against this version.

      /etc/init.d/thin start "appears" to start, but /var/log/thin/thin.0.log contains the following errors:

       

      /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:33:in `block in setup': You have already activated rake 10.0.4, but your Gemfile requires rake 0.9.2.2. Using bundle exec may solve this. (Gem::LoadError)

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:19:in `setup'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler.rb:120:in `setup'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler.rb:132:in `require'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/rhoconnect-4.0.0/lib/rhoconnect/application/init.rb:4:in `<top (required)>'

              from /opt/rhoconnect/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `require'

              from /opt/rhoconnect/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'

              from /opt/rhoconnect/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require'

              from /opt/nginx/html/myapp/config.ru:2:in `block in <main>'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/builder.rb:55:in `instance_eval'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/builder.rb:55:in `initialize'

              from /opt/nginx/html/myapp/config.ru:1:in `new'

              from /opt/nginx/html/myapp/config.ru:1:in `<main>'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/lib/rack/adapter/loader.rb:33:in `eval'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/lib/rack/adapter/loader.rb:33:in `load'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/lib/rack/adapter/loader.rb:42:in `for'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/lib/thin/controllers/controller.rb:169:in `load_adapter'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/lib/thin/controllers/controller.rb:73:in `start'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/lib/thin/runner.rb:187:in `run_command'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/lib/thin/runner.rb:152:in `run!'

              from /opt/rhoconnect/lib/ruby/gems/1.9.1/gems/thin-1.5.1/bin/thin:6:in `<top (required)>'

              from /opt/rhoconnect/bin/thin:23:in `load'

              from /opt/rhoconnect/bin/thin:23:in `<main>'

       

      Any assistance appreciated.

       

      Thanks,

      Andrew