4 Replies Latest reply on Sep 30, 2013 10:03 AM by David Miller

    RhoStudio cannot find fastercsv

    David Miller

      fastercsv is not found by Eclipse RhoStudio.

       

      I've installed a gem (rhohub-1.0) before on my OSX development machine, but fastercsv is not found after I've installed it.  This is what I did...

       

      I have RubyGems installed, so as per fastercsv install instructions I did this...

      sudo gem install fastercsv

      Fetching: fastercsv-1.5.5.gem (100%)

      Successfully installed fastercsv-1.5.5

      Installing ri documentation for fastercsv-1.5.5

      1 gem installed

       

      All goo so far!

       

      My controller contains require 'fastercsv'.

       

      When I run the app (in the simulator), I get ...

      Server Error

      Error: no such file to load -- fastercsv

       

      So I run a 'gem list' and 'gem which'...

      gem list

      *** LOCAL GEMS ***

      ...

      fastercsv (1.5.5)

      ...

       

      gem which fastercsv

      /Users/david/.rvm/gems/ruby-1.9.3-p392/gems/fastercsv-1.5.5/lib/fastercsv.rb

       

      In the past I've had to run a 'bundle install' in the gem directory (in this case, /Users/david/.rvm/gems/ruby-1.9.3-p392/gems/fastercsv-1.5.5).  But it fails as there is no Gemfile.  So I create one containing just...

      gem 'fastercsv'

       

      sudo bundle install

      Using fastercsv (1.5.5)

      Using bundler (1.3.5)

      Your bundle is complete!

      Use `bundle show [gemname]` to see where a bundled gem is installed.

       

      Close and reopen RhoStudio and try to run it again. Still no joy.

       

      Any ideas why Eclipse RhoStudio isn't resolving the require 'fastercsv' (also tried require 'faster_csv')?

       

       

       

      gem env output ....

       

      RubyGems Environment:

        - RUBYGEMS VERSION: 2.1.5

        - RUBY VERSION: 1.9.3 (2013-02-22 patchlevel 392) [x86_64-darwin12.3.0]

        - INSTALLATION DIRECTORY: /Users/david/.rvm/gems/ruby-1.9.3-p392

        - RUBY EXECUTABLE: /Users/david/.rvm/rubies/ruby-1.9.3-p392/bin/ruby

        - EXECUTABLE DIRECTORY: /Users/david/.rvm/gems/ruby-1.9.3-p392/bin

        - SPEC CACHE DIRECTORY: /Users/david/.gem/specs

        - RUBYGEMS PLATFORMS:

          - ruby

          - x86_64-darwin-12

        - GEM PATHS:

           - /Users/david/.rvm/gems/ruby-1.9.3-p392

           - /Users/david/.rvm/gems/ruby-1.9.3-p392@global

        - GEM CONFIGURATION:

           - :update_sources => true

           - :verbose => true

           - :backtrace => false

           - :bulk_threshold => 1000

        - REMOTE SOURCES:

           - https://rubygems.org/

        - SHELL PATH:

           - /Users/david/.rvm/gems/ruby-1.9.3-p392/bin

           - /Users/david/.rvm/gems/ruby-1.9.3-p392@global/bin

           - /Users/david/.rvm/rubies/ruby-1.9.3-p392/bin

           - /Users/david/.rvm/bin

           - /usr/bin

           - /bin

           - /usr/sbin

           - /sbin

           - /usr/local/bin

           - /usr/local/git/bin