2 Replies Latest reply on Mar 4, 2016 3:58 AM by erika contiero

    Rhoconnect set admin password fails

    Tahir Zamir

      Hi,

       

      rhoconnect 3.4.5

      centos 6.4

       

      I'm trying to set a password for rhoconnect. 

       

      Using the webconsole nothing seems to happen and a password is not created.

       

      Within a command shell, rhoconnect prompts for the existing username and password which are "rhoadmin" and blank.  At this point the following is seen:-

       

           Token is saved in: /home/.../.rhoconnect_token

       

      and then for the new password.  It fails setting the new password with:-

       

           Run rhoconnect command error: 500 Internal Server Error: undefined method 'update' for nil:NilClass

       

      I don't know if this has any bearing but I am executing the set-admin-password from the folder which contains my rhoconnect app.  If I run it outside of this folder then the command returns with, "settings.yml" not found.  Does settings.yml need something specific to effect a change of password?

       

      Regards,

       

      Tahir

        • Re: Rhoconnect set admin password fails

          Yes it's likely that command broke with some changes to 3rd party library RestClient.  Easiest thing to do is change it through the web console.

          • Re: Rhoconnect set admin password fails
            erika contiero

            Hi Tahir,

             

            I had the same problem on rhoconnect v.4 and v.5.1.1, and when I was looking for a solution I found your question here.

            I solved this issue using the direct RestClient call to change the password:  RestClient.put("#{server}/rc/v1/users/rhoadmin"...

            I attach the ruby file, you can set your parameters inside it and then you can execute this (with a shell on a machine that can reach your rhoconnect) with the command:

            ruby set_admin_password.rb

             

            Maybe now this information is no longer useful for you, but if someone have to solve the same problem can try this workaround.

             

            Bye!

             

             

            Erika