10 Replies Latest reply on Oct 25, 2013 7:26 AM by Daniel Silva

    enable :full_update is not working

      I have upgraded my code to use rhoconnect-client versus Syncengine but I am unable to get the the :full_update working. My update_hash in rhoconnect always contains only the changed attributes. Am I missing something on the rhoconnect side that needs to be done? Is there a way to 'touch' the property I need to send without changing its' value?

       

      Here is my model definition:

       

      # The model has already been created by the framework, and extends Rhom::RhomObject

      # You can add more methods here

      class NXDActivity

        include Rhom::PropertyBag

       

        # Uncomment the following line to enable sync with NXDActivity.

        enable :sync

       

        enable :full_update

       

        belongs_to :request_id, 'NXDRequest'

       

        set :sync_priority, 10

       

         #more stuff here ...

      end

       

      Robert