Redis 2.6 integration to Rhoconnect

I just want to ask when will Rhostudio integrates Redis 2.6 to Rhoconnect since this stable released coming from

Microsoft Open Technologies would enable Rhoconnect Server to be deployed in Windows platform

in production environment.

Also, can the Rhoconnect Team provide us step by step procedure to manually override the redis

component in the Rhoconnect server to be able to use the Windows version of Redis 2.6?

It would be convenient for us to use same Windows Platform as our Rhoconnect Server

just like our web server.

Regards,

Vine

John Michael Vi...
Wondering why this issue

Wondering why this issue seems unimportant to the Rhoconnect team.

It would be so much convenient for developers to use windows server

as production server!

Its been 5 days and no response...

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kutir Mobility
Hi John, You can try it on

Hi John, You can try it on your own right? Like running the RhoConnect on Windows and have it pointed to Windows Redis server? :development:   :syncserver: http://localhost:9292/api/application/   :licensefile: settings/license.key   :redis: localhost:6379 :production:   :syncserver: http://localhost:9292/api/application/   :licensefile: settings/license.key   :redis: localhost:6379 :test:   :syncserver: http://localhost:9292/api/application/   :licensefile: settings/license.key   :redis: localhost:6379 Visnupriya Kutir Mobility

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Toews
John,     I apologize for the

John,

     I apologize for the lack of response. As far as using the stable version of Windows Redis, it should work fine, and most likely does however, it is not something we have tested and therefore do not fully support it.

To override the redis you use, all you have to do is change the address in your settings.yml at <path_to_rc_app/settings/settings.yml>. By default, the production settings look like this:

:production:

  :licensefile: settings/license.key

  :redis: localhost:6379

  :syncserver: http://localhost:9292

  :push_server: http://someappname@localhost:8675/

You simply need to change the :redis seting here to your desired address and port.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


John Michael Vi...
My concern is not regarding

My concern is not regarding the server url and port of redis server. This is about

overriding the redis-server application itself being used by RMS 4.0 Rhoconnect Application.

Currently Rhoconnect is using redis 2.4 version. But I want to use the stable version from Microsoft Open

Technologies which is redis 2.6.12 as of now. I have already installed it in my PC and once I started

the redis 2.6 version it displays a command prompt with success message of instantiating the server

with the default port. But once I started the Rhoconnect server from the Rhostudio, it can't start up due

to the port being used by the standalone redis server I have. it seems that Rhoconnect is still trying

to run its own redis server which is the redis 2.4 and disregard the running standalone one.

So my question means, how could I make rhoconnect used the standalone one or just change the redis application

used in the Rhostudio and replace it with the new version?

Take note, this is for Windows platform.


Regards,

Vine

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Toews
John,     When you start

John,

     When you start RhoConnect on Windows machines, it starts redis for you. So if you start redis and tie up the port that RC is going to try to start redis on, it will not be able to start it. Please make sure the line in your settings.yml for your redis server is correct and then start RhoConnect without redis already started and RC should automatically start the redis your settings.yml is pointing to.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


John Michael Vi...
I think I am not being clear

I think I am not being clear here.

I know Rhoconnect starts it own redis server. The problem is, it is using the 2.4 redis version.

I want to use the stable version from Microsoft Open Technology which is 2.6 version.

That is why my question was how to override the redis server in the Rhoconnect. I don't want to use

the 2.4 version, I want to use the stable version of Rhoconnect in windows which according to Microsoft

is production tested and ready.

I hope I could get satisfying answer, since we are having a great project and once Rhoconnect could

be deployed to windows server, it would be really convenient for us. And we would really

grab RMS 4.0 completely.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Mark Nongkhlaw
John, I'm just curious here.

John, I'm just curious here. Did you edit <path_to_rc_app/settings/settings.yml> and in particular, the

:redis: entry to point to 2.6 version of MS Open Tech Redis? Are you saying that RC still uses the 2.4 version even if that is done?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


John Michael Vi...
Alright you are saying I have

Alright you are saying I have to change the port of the redis server in the settings.yml.

That could worked. Still the rhoconnect app is deploying another redis server instance

of 2.4 version.Also, I have to manually start the redis server 2.6. It would be convenient

if I could directly tie up redis 2.6 and rhoconnect app. That would be a lot cleaner

solution.


Regards,

Vine

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


John Michael Vi...
Another thing, since

Another thing, since microsoft open technologies assure us of the stability of redis 2.6 windows version,

can someone from rhoconnect team help me out on deploying rhoconnect application

as a standalone server app on windows platform for production environment

using redis 2.6 version?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Toews
Since it is not a supported

Since it is not a supported product combination, we do not offer any kind of tutorials for things like this. Setting up a RhoConnect app in a custom way is up to you.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Mark Nongkhlaw
Also, can the Rhoconnect Team

Also, can the Rhoconnect Team provide us step by step procedure to manually override the redis

component in the Rhoconnect server to be able to use the Windows version of Redis 2.6?

+1

Looking forward to a full Windows installable of Rhoconnect which includes the Windows version of Redis 2.6 for both dev and production

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Andraž Stošić
John Hi,I think I found

John Hi,

I think I found solution for your question. You can change default version of Redis instance when starting Rhoconnect application in rake task (pathToRubyInstalation\lib\ruby\gems\1.9.1\gems\rhoconnect-3.4.5\tasks\redis.rake)

There you can change variable REDIS_RELEASE to Redis version you would like to use on start.

Let me know it this helped.

Regards!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments