5 Replies Latest reply on Dec 5, 2013 9:47 AM by Lars Burgess

    Rhoconnect-push command line port change not working

    Graham Bird

      According to the documentation here we should be able to specify the port that Rhoconnect-push starts on using the command line:

      Rhomobile | Setting Up for RhoConnect Push Service on Client Application

       

      I have tried the following four options with results detailed below each pair (since the results were the same whether using -p or --port:

      > rhoconnect-push -p 9299

         ansServerPort not specified - setting to default "5000"

      > rhoconnect-push --port 9299

         ansServerPort not specified - setting to default "5000"

      For either of the above options, the service was indeed running on port 5000 rather than 9299

       

      > rhoconnect-push -p9299

      > rhoconnect-push --port9299

      For these two options, the service runs on 8675 (the default if not port is specified in the command line)

       

      I have also tried putting quotes around the number (just in case) but this had no effect on the result.

       

      In the end, for the time being, I have set up a config.json file with the settings for the push service and run using the command "rhoconnect-push -c config.json" but would appreciate finding out if I am doing something wrong, if this is a bug in the command line for the service (which is what it appears to be) or if the documentation is wrong.

      The version of rhoconnect-push is 1.2.2.

       

      Kind regards,

      Graham Bird.