Rhoconnect push problem: no device parameters

Hello,

we are trying to perform a push notification from Rhoconnect to an android app.

Rhoconnect is installed in a CentOS and it communicates to our backend with SOAP messages through web service.

For setting up the application we have modified the rhoconnect-push inside the samples folder following the webinar guide.

We do the following step:

- Start Rhoconnect

- rhoconnect-push

- install the rhoconnect-push-service.apk

- install rhoconnect-push.apk

When we do the login, the server accept our string and we see the user in the rhoconnect console, but we have only four fields associated (rho__id, user_id, last_sync,app_id).@

From the app, opening the log, we have noticed the following errors:


- ClientRegister|Device PUSH pin is empty, do register later

- ANSBroadcastReceiver|Rhoconnect-push registration error:SERVICE_NOT_AVAILABLE

- APP|Params:{"__rho_object"=>{"__rho_inline"=>"0"},"rho_callback"=>"1","error"=>"SERVICE_NOT_AVAILABLE"}

Where we can watch for detect the error, where is the wrong setting?


Thanks, best regards,

Federico

Lars Burgess
Hi,Are you seeing any

Hi,

Are you seeing any activity in the rhoconnect-push server logs?  Try running it with

     $ rhoconnect-push -d 3

To get the most verbose output about all client connections, etc...

Also, can you paste your rhoconfig.txt section that specifies the rhoconnect & push server locations?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Federico Giardina
Hello Lars,when I run the

Hello Lars,

when I run the "rhoconnect-push -d 3" and a device do the login, I see this lines writing on the output (I try only one login)

Immagine.png

The rhoconfig section that specifies the rhoconnect servers are

Immagine.png

Thanks, best regards,

Federico

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Lars Burgess
Please remove "/application"

Please remove "/application" from your syncserver setting.  It is not used in 4.0 applications.  Since you set the push_appname to 'test' did you also set it in settings.yml to 'test' ?

:push_server: http://test@localhost:8675/

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Federico Giardina
I'm sorry Lars, I forgot to

I'm sorry Lars, I forgot to tell you I develop with RMS 2.2.1.12. I still have to remove the "/ application"?

My settings.yml file is

Immagine.png

Federico

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Lars Burgess
The rhoconnect push server

The rhoconnect push server was a beta release in 2.2, please try 4.0 as a lot of issues were fixed in this release.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Federico Giardina
Hi Lars, I've tryed to

Hi Lars, I've tryed to perform the push with RMS 4.0.0 and RhoConnect v4.0.0 and we have the same error.

I send you the screen of the our settings.

settings.yml

due.png

rhoconfig.txt

tre.png

and the execution of the rhoconnect-push -d 3

uno.png

where we wrong the settings?Have you an idea?


Thanks, best regards,

Federico

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Lars Burgess
Is your push server able to

Is your push server able to connect to the rhoconnect server?  The default url it uses is "http://localhost:9292" (your rhoconnect application).  Maybe there's an issue with your machine and localhost connections?  You can try setting the host from the command line:

$ rhoconnect-push -i 10.127.5.171 -d 3

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Federico Giardina
Hi Lars,I've tried to do a

Hi Lars,

I've tried to do a ping command from the server to his localhost and it worked (The port is opened and the service is listening).

After I tried to perform a push call using before your command for setting up the host but I have the same error response of the first post (SERVICE NOT AVAILABLE).

Which other operation can I try?

Federico

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Lars Burgess
Sorry there's not much more I

Sorry there's not much more I can suggest other than testing network connectivity between all of the nodes.  Maybe try disabling your firewall and making sure all devices are on the same local subnet?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Federico Giardina
Hi Lars,we had tried to

Hi Lars,

we had tried to operate with another enviroment with all devices in the same subnet (rhoconnect and rhoconnect push service) but we had the same result, the service didn't work.

Reading the log we have noticed that :

- from rhoconnect-push

RhoConnect push server started...

## handleCreateInstanceID header(s) {"connection":"keep-alive","authorization":"Basic c2Ftc3VuZyBtMF85MGY1NTI1Yi1lZDk0LTNlYTQtYjdhNi1hYjdkMzYzNjdlNjE6eyJ1c2VyIjoi","ujcilcjwyxnzd29yzci6ijeymzq1niisinnpdguioiiilcjwzxjjb3jzbyi6iiisimnsawvudguioijcrvjfvfrblvrfu1qilcjpbm91dci6imluiiwiy2xpzw50awqiom51bgx9cookie":"rhoconnect_session=BAh7CEkiD3Nlc3Npb25faWQGOgZFRiJFZmIyZTg1YjhhYjQyYjQ2YmU4ZTlh%0AMWM3YWJlNmU5OTkzM2FhYTBlMjk0YWNmMDRhMGE5NDUzNzY2MGQ5MmI1NUki%0ACmxvZ2luBjsARkkiNHNhbXN1bmcgbTBfOTBmNTUyNWItZWQ5NC0zZWE0LWI3%0AYTYtYWI3ZDM2MzY3ZTYxBjsAVEkiDWFwcF9uYW1lBjsARkkiEGFwcGxpY2F0%0AaW9uBjsARg%3D%3D%0A--d4b5c869d7e626896ea9b7136fee62de46313545;","content-length":"0","host":"172.16.6.152:8675"}

Invalid authentication credentials

- from rhoconnect service

>> Maximum connections set to 1024

>> Listening on 0.0.0.0:9292, CTRL+C to stop

127.0.0.1 - - [19/Dec/2013 17:36:03] "GET /rc/v1/app/rps_login HTTP/1.1" 404 569 0.0036

We didn't modified the samples application included in the installation of Rhostudio.

Have you any idea about this log messages?

Thanks,

Federico

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Lars Burgess
Strange, the fact that you're

Strange, the fact that you're seeing this:

     127.0.0.1 - - [19/Dec/2013 17:36:03] "GET /rc/v1/app/rps_login HTTP/1.1" 404 569 0.0036


Means that the route doesn't exist.  Did you add it when you migrated your rhoconnect app to 4.0?


http://docs.rhomobile.com/en/4.0.0/rhoconnect/migration#migrating-application-files



Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Federico Giardina
Is it necessary to upgrade

Is it necessary to upgrade rhoconnect and rhodes or is it possible to upgrade only rhoconnect to 4.x version?

Best regards,

Federico 

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Lars Burgess
Yes, rhoconnect 4.0 only

Yes, rhoconnect 4.0 only works with rhodes 4.0+.

-Lars

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments