9 Replies Latest reply on Feb 18, 2014 7:06 AM by Arsalan Azeem

    configuration

    Arsalan Azeem

      I am new in rhomobile when I run project following errors show please help me:

       

      build started

       

      PWD: C:\Users\Zaheer\workspace\Testapp

      CMD: rake run:android:rhosimulator rho_debug_port=9000 rho_reload_app_changes=0

      cd C:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0

      rake aborted!

      Invalid argument - javac -version 2>&1

      C:/Users/Zaheer/workspace/Testapp/Rakefile:36:in `load'

      C:/Users/Zaheer/workspace/Testapp/Rakefile:36:in `<top (required)>'

      (See full trace by running task with --trace)

      RET: 1

      Error in build application. Build is terminated.

        • Re: configuration
          Derek Warren

          Have you installed the Java JDK and pointed your project to the installed directory?

           

          Setting the JDK Path

          Go to RhoStudio Preferences (Windows –> Preferences), select RhoMobile section and set the Java bin path. Set this path to JDK, such as C:\Program Files\Java\jdk<version number>\bin .

            • Re: configuration
              Arsalan Azeem

              Yes, but now it show following error:

               

              build started

              CMD: rake run:android --trace

               

              Cannot find your Rhodes gem or source path: C:/MotorolaRhoMobileSuite4.0.0/ruby-1.9.3/lib/gem/gems/rhodes-4.0.0/Rakefile

               

              If you have the sdk on your path or have installed the gem this

              can be resolved by running 'set-rhodes-sdk'

               

              You can also set this manually by modifying your build.yml or

              setting the environment variable RHO_HOME

              RET: 1

              Error in build application. Build is terminated.

            • Re: configuration
              Arsalan Azeem

              Again it started to giving me same errors as i described on top , i insatalled it again.

              its the error

              PWD: D:\RhoWorkspace\RhoMobileApplication1

              CMD: rake clean:android

              cd D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0

              rake aborted!

              Invalid argument - javac -version 2>&1

              D:/RhoWorkspace/RhoMobileApplication1/Rakefile:36:in `load'

              D:/RhoWorkspace/RhoMobileApplication1/Rakefile:36:in `<top (required)>'

              (See full trace by running task with --trace)

              RET: 1

              build started

              PWD: D:\RhoWorkspace\RhoMobileApplication1

              CMD: rake run:android --trace

              cd D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0

              rake aborted!

              Invalid argument - javac -version 2>&1

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0/Rakefile:875:in ``'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0/Rakefile:875:in `block in <top (required)>'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/task_manager.rb:196:in `in_namespace'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/dsl_definition.rb:104:in `namespace'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0/Rakefile:462:in `<top (required)>'

              D:/RhoWorkspace/RhoMobileApplication1/Rakefile:36:in `load'

              D:/RhoWorkspace/RhoMobileApplication1/Rakefile:36:in `<top (required)>'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/rake_module.rb:25:in `load'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/rake_module.rb:25:in `load_rakefile'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:589:in `raw_load_rakefile'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:89:in `block in load_rakefile'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:160:in `standard_exception_handling'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:88:in `load_rakefile'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:72:in `block in run'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:160:in `standard_exception_handling'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:70:in `run'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rake-10.0.4/bin/rake:33:in `<top (required)>'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/bin/rake:23:in `load'

              D:/MotorolaRhoMobileSuite4.0.0/ruby/bin/rake:23:in `<main>'

              RET: 1

              Error in build application. Build is terminated.

               

              its the build.yml

              #sdk: "C:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0"

              sdkversion

              : "4.0.0"

              name: "RhoMobileApplication1"

              version: 1.0

              vendor: "rhomobile"

              build: "debug"

              bbver

              : 6.0

              applog

              : "rholog.txt"

              iphone

              :

                configuration: "Release"

                sdk: "iphonesimulator6.0"

                provisionprofile:

                codesignidentity:

                entitlements:

                BundleIdentifier: "com.rhomobile.rhomobileapplication1"

                BundleURLScheme: "rhomobileapplication1"

              wp

              :

                productid: "1a65c021-7569-0131-6b48-001b11c0e72e"

              symbian

              :

                uid: "0xec2dd74c"

              android:

                version: "4.0.3"

                emulator: "testDevice"

                capabilities:

              extensions:

                - rhoconnect-client

              capabilities:

              sdk

              : "D:/MotorolaRhoMobileSuite4.0.0/ruby/lib/ruby/gems/1.9.1/gems/rhodes-4.0.0"

               

              Now i dont know what to do with this .

                • Re: configuration
                  Peter Arcuri

                  I think your ruby gems need upgrading. RMSv4.0 should be using ruby 1.9.3.

                  • Re: configuration
                    Daniel Silva

                    Ruby 1.9.1 is what gets installed on Windows with RhoStudio, and it works OK on my system, so I think that is OK.

                     

                    I know you have re-installed RhoStudio a few times, but did you uninstall the old version first?  There can be conflicts if you have multiple installations on the same machine.  I see that you have switched from C to D drive, just wondering if there are other installations on this machine that might be causing some of your issues.

                     

                    If that doesn't help, this issue seems related to the JDK install/configuration.  Can you attach your environment variables for your system?  You can go to the command line and do set  > env.txt <enter> to send them to a text file named env.txt.

                     

                    And please also let us know what version of the JDK is installed on your machine and what folder it is in.  Also if you attach D:\MotorolaRhoMobileSuite4.0.0\ruby\lib\ruby\gems\1.9.1\gems\rhodes-4.0.0\rhobuild.yml, that may help.

                     

                    Adding below some of the settings from my Windows system in case it might help.I am running a Windows 7 64 bit machine using 64 bit Java JDK 1.7.0_45.  I have the below environment variable set.

                    JAVA_HOME=C:\Program Files\Java\jdk1.7.0_45

                     

                    I also have added the path to the java JDK in my path environment variable.

                    ...;C:\Program Files\Java\jdk1.7.0_45\bin;...

                     

                    And the top of my rhobuild.yml looks like this.. (this is what gets set when you set the preferences up in rhostudio/eclipse)

                    env:

                      paths:

                        nsis: "C:/Program Files (x86)/NSIS/makensis.exe"

                        java: "C:/Program Files/Java/jdk1.7.0_45/bin"